VST3 midi channel selection issue in Studio One


I have reported this before, but it’s a major issue, so i will post about it again in this new forum.

It’s unfortunately not possible to select a midi channel for Arturias VST3 plugins in Studio One. It’s possible for some other VST3 plugins, so it look like a Arturia issue.
It’s also possible with Arturias VST2 plugins, but they do not accept Studio Ones new Sidechain input like the VST3 does. Studio One give VST3 priority for Arturias plugins as they apparantly share the same ID, so it’s not possible to access both VST2 and VST3 versions.

So it’s in example not possible to access all b3’s manuals - one for each track in the DAW using different midi channels. So you have to use a plugin for each manual, instead of using the same plugin for all manuals.

Please fix.

1 Like

Hey @LBH thanks for your feedback on V-collection 9,

This needs a deep look from our team, please log in to your account to contact our support team that will help you to fix this situation.


Hi @sand.arturia

It’s actually quite simple. I attach screenshots here from my laptop away from my controllers. Please forward.
Like you can see on the image, then Pigments VST3 does’nt get any option to select midi channel. (Red arrow.) There is only a selector on the IN channel not the OUT channel.
It’s the same for all Arturias VST3 software instruments.

Other VST3s get that selector.

S1 Inspector

1 Like

Got it. The team took note & will fix this for the next version
Thanks again @LBH :zap:

1 Like

That’s great @sand.arturia

1 Like