V collection 9 no longer recognising my licsense

Hi All . Newbie here.
SO reinstalled all my AU’s on new MacBook pro, using Logic pro x. and since new install V Collection 9 is saying that I dont have licenses for synths that come with the package. Example Juno 8 V4.
I have all the previous V collections. and Software Center clearly shows that all licenses are in place. I can t understand why suddenly not allow full access to them.

Any help be greatly appriceated

Did you contact customer support?

Hi @jnr_jay . Welcome to the community.

I assume you mean you have Jup-8 V4.

If you have activated V-Collection 8, then i can suggest you try to deactivate it. Then - just in case - restart your computer and activate V-Collection 9 again.
This have helped before.

Just in case: Older V-Collections that have older discontinuet versions of applications also have to be activated, if you have installed the older applications like i have.


I did indeed but they informed me they are extremely busy so may take time.


Awesome I will take a look at this

Appreciate the supply


Thanks so much. Worked a treat.

Is it normal for Arturia to remove full access to some synths on new versions. I just presumed they all remained.

So im still not sure if I’m running Juno 8 v4 from vCollection 8 or 9 but hey it works. Hahahha

Glad it helped.

The main thing in this case was to deactivate and then activate V-COllection 9 again. This have solved it for all the applications in V-Collection 9.

When you have a version like a V4 of an application in multiple V-Collections, then it’s the same version in all applications.
But for example a V3 version in one V-Collection and a V4 version in another V-Collection is’nt the same. So to get this older versions to work, then they also have to be activated, but it has nothing to do with a newer versions.

BTW: I can see i have written V-Collection 8 one time where i meant V-Collection 9. That may have caused some confusion.