Stuck notes problem is back all of a sudden

a few years back a lot of us had a big problem with stuck notes that got resolved (mostly) with a firmware update. Since then I didn’t have any problems at all.
Today I woke up and wanted to play some piano after and guess what… the stuck notes problem is back!
I don’t have any clue what happened or what is different from the last time I played. I feel like I tried everything:
Different cable
Different PC
Different USB port
Reinstall of the software and drivers
Factory reset of the Keylab Ess 88
Update the firmware (it’s on the latest)

I ran out of ideas of what could cause this problem… Here is a picture of my piano after playing random notes for 4 minutes:

The lights represent the stuck notes - I have a LED visualizer and no, the issue is not caused by the visualizer, I tried to unplug it and still got stuck notes.

Please help me… I really love this keyboard but this is just so annoying :frowning:

Could anyone help me please? :frowning:

Hey @C0dyTheDev welcome to our Sound Explorers community!

As this is a very specific situation we invite you to please log in to your account and contact our support team that will help you to fix this situation ASAP.

Also we kindly invite you to read our Code of Conduct to get the most from our community!

Keep exploring :zap: