Pigment sounds in saved project suddenly load generic patch

A project I’ve been working on for months has suddenly this morning loaded all Pigments incidents as the Welcome patch. I worked on it yesterday with no apparent issue.

So far only the one project has been affected, but all 10 pigments in that track have lost their sounds.

When going through the backup projects that FL automatically saves every 10 min or so, only the very first backup has all the correct pigment sounds, every one that FL auto-saved after that one have the same issue (not the correct patch).

Using the lasted version of FL studio.
Win11, amd ryzen 9, 32g ram

1 Like

Hi @andytronic . Welcome to the community.

Perhaps it’s best to contact Arturia support through your account about this one, at least if no one using FL Studio have it working and can help you.

I’m currently having the same issue with Pigments 5.0.1 in the most recent version of Bitwig on Windows 11. Came here to see if a solution had been posted; looks like I may also be contacting support soon.

Edit: I’ve contacted support and am waiting to hear back. Another user experienced this issue in Ableton and Logic: Not loading presets when reopening project

I heard back from support, and they recommended deactivating and reactivating Pigments through Arturia Software Center. After that (and a few other things I tried) didn’t work, I came up with the following workaround. Because it’s quite tedious, hopefully they’ll be able to suggest something that fixes the issue directly.

In the meantime, this workaround might help someone else experiencing a similar issue:

-I uninstalled the most recent version of Pigments.
-I downloaded and installed legacy Pigments version (Important: Make sure it’s activated and not in demo mode; otherwise you won’t be able to save patches through it. I wasn’t able to activate it through the plugin’s activation menu; it had to be recognized by Arturia Software Center, and I had to install it twice for this to occur–possibly because it’s so out of date.)
-I opened the most recent version of the song file (from about 6 months ago) in the most recent version of Bitwig, and checked to make sure the proper patches loaded into each instance.
-While the Bitwig file was open with legacy Pigments installed, I manually saved every loaded Pigments patch under a brand new name (I just used a combination of the song and track name to make them easier to find and re-load into the proper track in the next step). I then closed the Bitwig file without re-saving.
-I re-updated to Pigments and re-opened the Bitwig file. I then manually loaded the newly-saved patches into each corresponding Pigments instance one by one.
-I then saved the Bitwig file as a new version, and re-opened it. Yay! The proper patches are now loading!

The above approach may or may not work for your situation. It may have worked for me only because the instances of Pigments in this song were using few/none of the new features added between versions 2 and 5. I initially also tried a few later legacy versions of Pigments, but those also loaded the generic patches. I have no idea why v2 was the only one that would work.

I’m keeping my fingers crossed that I don’t come across this unusual issue in any more files.

1 Like

Hello guys.
If any of you faces this issue, please don’t hesitate to contact our support team with the maximum information about your setup, your project and what was the context when facing this issue…