Is it safe to rollback MiniFreak firmware?

Ever since the 2.0 update my setup does no longer work (as explained in this thread). This situation has not yet been resolved.

Since I want to start making music again, I think of rolling back the firmware too, so I can again connect with MiniFreak V.

Does anyone have experience with rolling back the MiniFreak firmware from 2.0 to the previous version?

When I upgraded to 2.0 initially, I had a looot of trouble, with my synth becoming bricked for a while. I managed to get it working again after several hours. So I’m naturally quite scared to try rolling it back again. Do people here have experience with this, or is it better not to try?


HI @Square

It’s not something i’d personally attempt, so i’d advise against and hang on until support get back to you. I DO understand your frustrations, i’m waiting on a rather expensive bit of kit to be repaired, with a different company, they said it would be likely a couple of weeks but they have a rush on currently. I know they’re being straight with me as i took the unit there myself… doesn’t stop the frustration unfortunately though.

Hi there. I have successful rolled back from an faulty 2.0 Version!

First I tried about 10 times updating to 2.0 with always different results:
no screen, no sound, fonts broken in display, crash after using favorites and so on.
My luck was that it was always possible to start into bootload-mode with that key-combination of “Shift + Octave down”.

I used the MicroFreakV on an VirtualBox VM with Windows10 on a linux host system.
The breakthrough to an successful working update to V2.0 happend when I upgraded my VirtualBox from version 6 to the latest version 7.0.12.

It seems that the update-process over usb is very very unstable, because all my failed update-tries showed in MiniFreakV something like: “update successful”, but then the hardware never started by itself. After manually restarting (after minutes of waiting) it had always some problems, which made it unusable. So there is no check on the update-process to see if the update was flawless - there should be some checksum beeing used to see if everything looks good.

Luckily I was able to downgrade to version 1.1 after 1 or 2 tries (cant remember exactly) and used it for a couple of days - only fault was that my former last user preset on position like 360 or so, was displayed but when selected was an init-preset. This behaviour was fixed after the successful update to version 2.0 later…

After updating my virtualbox to version 7.0.12 I gave it another try which worked finally.

The working MiniFreak 2.0 is great fun - thanks to arturia!
The update-process is very bad as it is now …

Hope that helps

1 Like

HI @marturi.9.bacfree
It’s great to see you’ve made it over here to the new Sound Explorers Forum.!

Many thanks for your input here, it’s reassuring to hear your experience is going so well and how you got there eventually.