[Feature Request] Step Sequencer independent play with external clock

Can we have an option so we can have Step Sequencer in local mode when external clock is enabled? I mean, without using start/stop transport messages from a daw?

What i mean is, in my case i use ableton and while performing i have ableton always in play mode because of other clips/tracks.
In this scenario, i can’t use step recording step by step because step recording will start playing every time.

If we had an option so the step sequencer with external mode to be independent (local)/not use the transport start/stop messages from ableton, only the bpm it would be awesome. Or if anyone knows how i can achieve this it would be great.
My only trick it to set the clock to internal and set the clock my hand to same as the daw, but that breaks the workflow because every time i change the time on the daw i have to set it manually on the minifreak, bit at least i can use the step sequencer without auto starting to play even if the daw is playing…

2 Likes

Hi @calhaus thanks for your feedback on the MiniFreak improvements!

We will mark this topic as a feature request to let our team know about it.

Please make sure to subscribe to our Newsletter 1 to be the first to know about them.

For now, the only solution i’ve got to make the step sequencer work with external clock enabled (and while the transport is on/ableton is in play mode) is to use midi-ox.

-I’ve set ableton to sync is clock to a digital midi port cleated with “loopmidi”
-Then using Midi-ox i’ve set loopmidi port as input and routed only clock messages and filtered “start” clock messages and sent them to minifuse input port
-Connected a midi cable from minifuse output to minifreak’s input.
-And finally in ableton i’ve set a a button to send a midi message to the loopmidi port with a ableton device and in midi-ox i’ve convert that message to a stop signal.

It’s way far from ideal, but it’s the only way to make it work

if the transport comands could be independent from the external clock it would be very simple

1 Like

It would be fine if the arpeggiator/sequencer triggered on key/play button press. (With external clock) I have both micro and mini freaks and i can’t play them live with this forced quantization (or maybe without midi but it’s not so fun )
Or just turn off arp sync but listen to bpm somehow.
Edit: on the micro, the sequencer works fine, starts in time, on key push too, but on the minifreak it’s quantized to master tempo Why?
The arpeggiator always quantized on both machines. The arp/seq should work (on both) like the microfreak sequencer PLEASE!!!

2 Likes

Hi @sand.arturia any update regarding this one? I am trying to sync my Akai mpc live 2 with my minifreak sequencer. It would be really helpful to get this feature addressed.
Thanks!