DAW Selection Screen Issue on the Keylab Essential 61 MK3 (see video attached)

I am pressing the prog button to get to the DAW menu, but then what as none of the bottons or select dial do anything. See video linked below on my Google Drive. I read the manual and searched for videos of others selecting their DAW, but non show the exact button combo. I must be missing something here, like perhaps another guide or setup video.


You have to start ypur DAW on your computer to map everything.
What is your operating system and what is your DAW program?

I am using Reaper and I am only just now realizing the Essential lineup does not support but the higher end Keylab 61 MK2 does. Surely this is incorrect as the price for the supported Essential DAWs are basically the price difference between the Keylab 61 MK2 and the Keylab Essential 61 MK3…$300. I rather just return the MK3 and get an MK2 and continue to use Reaper as it is $60. Reaper support for the Essential lineup make more sense given the budget range. Again, I surely must be wrong. Right?

Thanks for the reply

Sorry, I can’t help you with Reaper, I’m using Cubase Elements (~€70,-).
This might be also interesting…
Midi to reaper

I have not bought Reaper yet as I only just started evaluating. How is cubase Elements? I will be making Synthwave and think Elements would meet my needs. What are the big features you are giving up with Elements over the more expensive cubase options?

I use Cubase since back in the 1980th on my old Atari ST. I used to play in a band in these days. When moving from Atari to a Windows PC I bought Cubase Elements and I never missed any feature that is only available in „higher versions“ of Cubase. I’m controlling 6 sw- and 4 hardware-synths at the same time using my Arturia keyboard and/or my guitar to midi equipment. On www.steinbetg.net you can list the differences between the versions they offer. Steinberg is since the early ´80th in the music sw business and it is worth to have a look at. They offer a free trial that works for 30 days to evaluate…
And: No, I‘m not on the Steinbergs payroll :slight_smile:

1 Like

Ok…I have Cubase up and running and tried both the Mackie and HUI DAW selections in Arturia’s MIDI Control Centre, and while I can play the keyboard and hear the sounds, the transport controls either do nothing with Mackie or plays a note when in HUI. Further, the DAWs selection still does not allow me to select the DAW after pressing Prog. I am now using Cubase. Thanks for the help.

For full functionality of the Arturia keyboard you need to download the MIDI integration script from the Arturia WEB-site and import it into Cobase…

Yeah…I realized that after I found the guide hiding in the script download. Thanks for the reply.

Update: Been in touch with Arturia support who have been great. We have tried many steps to rectify but nothing seems to fix the transport controls not working in Cubase. I even sent them a video of the entire setup process and they confirmed it was correct. They are just as confused as I am. I have no other MIDI devices or software. That said, I did try the demo of FL Studio and everything worked out of the box. This means the keyboard is just fine (I was wondering if it was faulty), but Cubase 13 for me at least is not. I am switching to FL Studio as I actually like it better than Cubase, but I have committed to continue to work with Arturia to solve th3 Cubase issue as perhaps others will encounter.