Cannot make firmware update to my MicroFreak

Hello. Before we get into this, I’d like to mention that I’ve tried every possible solution;

  • Powering my MicroFreak with its own adapter + a USB cable
  • Tried to do it with and without a USB hub.
  • Bought a separate cable to connect it without a hub to my Mac.
  • Tried to make the update on 3 different computers. (Mac Air 2020 Ventura, Mac Pro 2011, also PC)
  • I am sure that Midi Control Center is up to date.
  • I tried to uninstall and re-install the MCC multiple times.
  • Tried with different USB cables AND also a different adaptor just in case.

I literally don’t know what else I can do. My MF works without any issues and I can perfectly use it within Ableton but now that I’ve tried every possible way, I am worried that the root cause is the MF itself.

The error I am getting within the MCC app is “Failed to init Device Manager.” It does not read my MF and says the device is not connected although it obviously is.

Do you have a solution that comes to your mind like resetting the device etc.?
Been waiting to get a response from Arturia support but they still haven’t reached out to me yet.

Thank you in advance and I appreciate your time to read this.

HI @9neszie welcome to our Sound Explorers community!

We noticed that we already replied to your concern since the 19th June with all details needed to solve your situation, please let us know if all goes well and make sure to check the spam folder on your mailbox.

Also we kindly invite you to read our Code of Conduct to get the most from our community!