Bug report: VST3 midi control

This was reported last December: (Bug in Labs VST3) and is still an issue on the most current version of Analog Lab.

It happens with the VST3 version (not the VST or standalone) while using the MiniLab 3 Midi output.
The CC messages for instrument assigned knobs (knobs 1 to 4) turn them visually but do not affect the sound. This happens even if you change which CC is assigned.

You can test this by comparing it to what happens when using the mouse to turn the knob.

Thank you.

Hey @NickA thanks for reposting this.

I’ll let the team know about it.
Hopefully this bug will be fixed on future versions.

Best,
:zap:

You’re welcome @sand.arturia . I’m glad I could help.

1 Like

@sand.arturia
I should also mention that this was using Analog Lab Intro.

Noted @NickA thanks for clarifying.

Hi @NickA ,

I’ve just tried to reproduce this issue using Analog Lab Intro.

As far as I’m concerned, everything’s fine using the MiniLab 3 knobs to move the Analog Lab macros. The change in sound is audible.
(I tested using the MiniLab’s USB MIDI and MIDI DIN connections in Ableton, with VST3 format).

It would be interesting if you could share a bit more about your setup, such as the DAW you use and how your MIDI setup is configured (DAW MIDI settings and MIDI connections).

If possible, also try using the MiniLab to activate the Analog Lab macros in another DAW to see if the problem happens.

I look forward to hearing from you!

Bests,

1 Like

Hi, I’m having the same exact problem in Reaper (latest version): physical knobs 1-4 on my Keylab Essential are moving the knobs in Analog Lab V, but nothing changes in sound, on the other hand if I use the mouse to move the knobs they works fine. This happens with the VST3 plugin only, the VST and standalone works fine. Also, in Ableton it works always fine both with VST and VST3.
In Reaper I also still get the old, jumpy knobs bug, both with VST and VST3 plugins and affecting ALL knobs (faders work fine). When this longstanding and annoying bug will be fixed?

Hey @maxdis VST2 should work, could you please try it on Reaper and confirm if it works?

Best

Yes, VST2 works fine regarding the 1-4 knobs bug, but both VST3 and VST2 are very bad regarding the jumpy knobs bug

Hey @maxdis , thanks for notifying this.

We reported the bug and our team is working on it, we apologies for the inconveniences and hope to bring a solution soon.

Best :zap:

Hi @niks.arturia and @sand.arturia,

My experience is the same as maxdis in Reaper with the VST3 version.
Thank you for looking into it.

Apparently nothing of this has been fixed in Analog Lab “Pro”: in Reaper knobs are still jumping all over the place (both with VST2 and VST3 plugins); also with VST3, moving some knobs using the “physical” knobs won’t do anything to the sound (although the knob is visually moving), I have to use the mouse to have some effects on the sound.