[Bug?]Minifreak V MIDI Learn not quite working

Running Minifreak V in Studio One 5.5 in Windows 10 x64. Trying to link the knobs from my my external controller (old Novation Launchkey) to the macro knobs of Minifreak V- “InControl” is off and the knob’s input is not being taken by S1’s Device Control Map-- my knobs are working fine with other VSTs. Anyone else having this issue? Thought I’d ask here before putting in a support ticket. TIA!

2 Likes

Hi @pebblestream and welcome to The Sound Explorers Forum.

Thanks for reporting this, i’ll list it as a potential bug at the moment, to see if anyone else is having this issue or knows of a ‘workaround’.

HTH!

Ps,
Please make sure to subscribe to our Newsletter to be the first to know about all the latest and greatest news from Arturia.

1 Like

Hi Mat, thanks! I just realized I did not give enough details-- what happens is-- I empty the current MIDI CC mappings, select MIDI learn, then click on a macro strip icon to select it to be learned, and twist the knob on my controller-- now the weird thing is, Minifreak V detects me moving the knob and maps the control to the knob, however when I turn the knob, the value of the control it’s mapped to doesn’t change. Hope that helps clear things up a bit!

1 Like

HI @pebblestream

I’ve not been able to check on my own machine today as i’ve just been too tied up, if you can hang on until tomorrow i’ll have a good look at it then, anyone else please feel free to chip in meanwhile…

1 Like

Hi again Mat, thanks! No rush here, I’m still enjoying making patches even without the comfort of the real knobs, though they would definitely be nice-- and I realize it may take time to find the bug and fix it. Merry Christmas and a Happy New Year!

1 Like

Can confirm I’m seeing the same behavior here. It picks up the CC when learning but doesn’t actually respond to any.

1 Like

I’m having a very similar problem. MIDI learn hasn’t worked for me since first installing it on MacOS last year; yes, it will map a physical knob to a paramter on the VST, but it will not change the MIDI data after exiting MIDI Learn.

My KS37 works fine with other plugins but not with MiniFreak V.

Controller: Keystep37
OS: MacOS 13.5.2
DAW: Ableton Suite 11.2

1 Like

Same problem here, i was getting crazy. I was trying to midi map to change previous/next presets but it’s not working :frowning:
In ableton

1 Like

Same problem here. MiniFreak V recognizes me assigning the cc but then it doesn’t respond. Tried opening new instances on new instrument channels, nothing working.
I’m driving crazy and need to bounce and send a file for a pending mix down…

1 Like

Same : No Joy. I use the Micro(Freak), and It perfectly learns the MIDI CC, but does not however do anything when actually moving the knobs. Only the “Hold” button seems to actually work - nothing to do with Midilearn.

Maybe when MiniFreak H/W 2.0 gets a sound card capacity I’m getting one, but for the time it doesn’t and portability and real estate is a real problem.

I must bring an Audiofuse along just to get the signal back (from the Micro therefore), and taking along my Roland JD-Xi is a better proposition for live playing. I play on a Keyboard Stand with guitar pedals at my feet, not a DJ-booth, and have no intention on using tape duct for my beloved sound card.

A dedicated “MicroFreak” profile (and update I guess) would be even better, one that would associated the shift functions with the actual panel Layout and some controls of OSC 2 etc, but that’s another topic. Proper Midi CC learn/usage as advertised is needed first.

Hi… Having same problems here. I’m using an M-Audio Axiom61 controller and MIDI learn works fine for all the other instruments in the V collection except for the mini freak v. I click Learn > click the knob in the UI > twist the knob on my controller and it assigns it to the correct # knob in the list under the MIDI pane, but there’s no action when using the controller knob.

I have the same problem: want to use MiniFreak V standalone on 2022 Macbook pro with Novation Launchcontroll XL: Midi Learn seems to work, but actual control of nobs in Minifreak Software does not happen. Launchcontrol works fine with other programmes, such as Ableton LIVE.

Hi, has this made the list of bugs that need to be fixed? I’m having the same issue with the Minifreak VST using a Fantom 08 as a controller on Windows 11.

I am experiencing the exact same phenomenon in my environment.
This synth sounds great. I would be happy to be able to use it comfortably.

OS:windows11
DAW:Cubase13
MIDIKey:Komplete Kontrol S61 mk2

Same experience here - the VST3 plugin detects and learns incoming MIDI CCs but does not respond to them once learned.
It’s a great synth, but fixing this would make it even better.

OS: Mac OSX Ventura 13.6.7
DAW: Studio One 6.6

Same issue here inside Bitwig Studio and standalone version. Using a Keystep Pro and it will learn the controllers but that’s as far as it goes unfortunately. However, the Pitch/Mod strips work as intended.

It works perfectly using the VST Host module in VCV Rack when I route the controllers via the VCV MIDI CC>CV module and assign them to, for example, Macros 1&2, Gate/Splice. I’ve uploaded a screenshot of the VCV set up for info should anyone wish to try it :slight_smile:

M1 Mac Mini running Big Sur 11.7.10
Bitwig 5.1.9
VCV Rack pro 2.4.1