Analog Lab V & Pro Output & Midi settings

Hello community
“… give as much details …” - okeee, that’s going to be some longer than.
please bare with my English, I am Italian native.

I was using Analog Lab V and now Analog Lab Pro on macOS Catalina (iMac) and Ventura as well as Sonoma on MacBook Pro.

My midi-masterkeyboard is currently a studiologic SL 88 connected only via USB to the studiologic Mixface and that one only by USB to my macs, hence no power supplies all bus powered. Unfortunately the Mixface and SL 88 power switches are covered by my desktop and horrible to reach, although it doesn’t make any difference to my problem / question.
Than there is the AI, a Minifuse 2, that by itself has no power switch at all.
So the USB-A plugs of the Minifuse and SL MIxface are connected to a 4 port USB hub, each port switchable.
That way I can e.g. switch on the Minifuse only and use the monitors for listening my music-library on iMac only, or switch on the midis and use the setup to play.
The KRK monitors are routed through a 240V switch as well.

Now comes the daily routine when practicing / playing e.g. on Piano V3.

Start the iMac, switch on AI and midis on USB hub, switch on monitors.
In Analog Lab I chose Minifuse as ouptput, the SL Mixface as midi and I am fine to run, play and practice piano.

As I tend to put my Macs to sleep only and do not shut them down / restart thee for weeks, when my session comes to an end, I put my Mac to sleep and switch of the KRKs. As the AI and midis are not used I switch of their ports on the USB hub.
Evening I wanna do another session and wake the iMac by a space-key-stroke, switch on the 2 USB ports for Minifuse and SL devices and … BANG.
The iMac has automatically swapped to Minifuse as standard Input Output device, fine. Macs shows the MIxface is running but Analog Lab doesn’t remember the settings.

Waking from sleep the internal Mac speakers are always faster that the Minifuse and Analog Lab takes first active as it seems. And same for Midi, when entering Analog Lab settings it shows always ‘Build in Speakers’ selected for Output and for Midi it displays the 3 SL Mixface ports but none is selected / ticked.

It doesn’t matter any order in wich I switch on the USB ports or wake the iMac, the moment Analog Lab is active and running, when the mac goes to sleep and wakes up again, ‘Build in Speakers’ is selected for Output and Midi none of the available is ticked,

Analog Lab loses the Output & Midi settings always 100% and reproduceble in my case.
Further input … data, pics, screenshots, video required? please ask.

Any help is highly appreciated.

Hi @skyfreak . Welcome to the community.

The only explanation i can give is this:
When you shut down the USB for your controller and your MInifuse and put the computer to sleep, then the devices probably vanish from your system, so the software instrument/ application can’t find, read and select them, and then the settings is being lost. This give issues, when you start up again.

I would close the software instrument/ application. I assume you get the right settings, if you open the instrument/ application again after you have restarted your USB connections.

BTW: In generel i suggest you have a soundcard connected directly to the computers own USB port (not using a hub) if that’s possible.

I’ll second this!
USB hubs are notorious for causing issues, best avoided for audio interfaces if possible!

thx folks, but in case of Minifuse it would mean to use the USB plug to shut it off as it has no switch, and yet that doesn’t make a difference to the problem IMHO

I agree that the device vanishes from my macOS settings and also in
yet the Mac remembers it somehow, and also Ableton does.
so I would check Arturias end :wink:
Analog Lab and all the Standalone VSTs shall store the Minifuse or whatever last AI was used, on startup check if available and switch to it.
if not available switch to Mac default.
a little daemon that runs when analog lab to the standalone vst is started, when last audio interface chosen gets available switch to it.
Mac like :wink:
I wonder why all SW engineers always look first over the rim of the cup and not into :wink:

ok one more thought not make things complicated.
as described I need/want to switch each device seperately

  • the Krk monitors … easy, a simple AC switch in the power supply line
  • the minifuse … unfortunately no switch
  • 2 studio logic midi devices … always both simoultanoulsly
    hence the hub for the USB devices

analog lab remembers / sees name it as you like the midi devices even when powered off, they are still listed in midi-studio and when they are active settings of analog lab checkmarks them, fine

the audio device acts different, it dissapears in when not powered on like the minifuse. BUT !!! in when the minifuse is plugged in (powered-on) I can right click the audio devices listed and assign wether it shall be used for audio IN / OUT, so to speak SET AS DEFAULT.

now when switching off the minifuse the Macs audio settings fall back to build in mic and speakers, but when powering on it sets the minifuse as default and auto switches to minifuse.
so in macOS there is 2 states for sure

  1. SELECTED default device
  2. FALLBACK to build-in device

now in Analog Lab Settings for the audio there should be added / changed just one tiny thingy in the code for the audio selection
“use macOS Audio settings”
bang done … that is what I would expect from a proper thought and developed macOS app.

Am I picky? Well maybe, or even quite sure. I am a Mac veteran and evangelist. tried scripting Analog Lab, but so much hustle for a simple thing when done right in code.

Why all this?
Well I know the workarounds but that iMac and music station is my hobbieist setup.
The Mac is old white loads of ram (24) and is running catalina. so easiest for quick sit down would be, switch the minifuse and midi devices ON (as written no other solution I know the switched hub ports) and if not playing with headphones, switch on monitors as well.

know I have to wait for analog lab or any standalone VST to start :frowning:

I love apple and the community!
here we go, problem solved.

the problem was that the audio device disappears from the list in
so what I needed was a virtual device that aggregates the minifuse and another device, where the second needs no output but has to be always available.

voilá → BlackHole: Route Audio Between Apps
and in audio midi setup I created a new main.devices and assigned the minifuse as well as blackhole to that device and made it the main IN/OUT device.

and now analog lab pointing to the new main device never loses it.


So there excist a workaround. Good for you, if it’s easier for you to use that.
Thanks for sharing.

Sorry to bother, as an apple dinosaur I should have thought much earlier to check what brew offers.

Yet there should be an option in Analog Lab and all standalone VTSs choose “System Default” and the problem would be solved :grinning: w/o workaround.

I used Blackhole years ago for sth. similar but simply forgot.
Latency is no Problem at all, as nothing is assigned to BH no soul comes out of the Minifuse unless it is powered ON … me happy

The USB hub works w/o extra power supply flawlessly so far, but I could optional power it externally as well.

Everybody has its ticks and problems. For me I really like to just move over to the keys and start playing with the PIANO V3 start away.
And as I do not like the midi/AI/Mac running all day I love it now.
3 switches and hit space to wake Mac from sleep and after 10 seconds while taking place the setup is ready to run.
It is essential to me to have hustlefree access to my digital setup as if it was a real grand piano, open lid and start playing. Yet I love all the instruments sounds and packs to play with and experiment.
But just for Quick-15-min repetitions it must be as fast and easy as a real grand to start playing.

thx folks and again sorry to bother.
anybody having same issues, feel free to write/contact me.

keep jamming

It’s abosolutely nice to have things going fast and easy.

I made the personal experience, that for me I make fastest progress with 4-6 sessions of 10-15 mins. a day rather then 1 go for an hour or 1.5 hrs.

and it is so annoying when each time I need to click here, select a setting there, save this … ya name it.