Analog Lab CPU Cubase 12/13

Hello, I’m wondering whether anyone else experiencing freezes in Cubase (or any other DAW) when using Analog Lab in 16 tracks.

I often go for adding 16 tracks of Analog Lab in order to later browse through sounds and create my arrangement.

Yesterday I’ve noticed big freezes (with CPU usage >40%) and in the end Cubase hangs.

I’ve tried some other VSTis I have which are CPU hungry (Omnisphere and other) and I haven’t experienced this.

Needless to say that with previous versions of Analog Lab I didn’t have such issues, even when loading templates with 32 instances.

Hi mchantzi,

I may have something to say on this but I have to check again in Cubase and Reaper.

Would you specify OS details? Windows 10 or 11, if applicable?

I’m using the Analog Lab feature restricting chosen instrument to specific channels (eg. in a multi, first instrument responds to channel 1 and second instrument to channel 8). Is it a new feature or am I discovering an old feature? It may have something to do with what I would call a crash rather than a freeze.

Hello Francoise,
I’m on win11. On a Mac (M2) here, things tend to be slightly better though the CPU shows a ridiculous 200+% and I see the Mac suffering :smiley:

I’ve tried many VSTs (Diva, Pigments, Massive etc etc and all Arturia’s V collection instruments I use) none of them got Cubase into this issue. In fact no combination of the above got me to more than 4% of CPU.

My specs: Intel I7-9700F. 64GB RAM, 2 4TB Samsung EVO 860 and a Radeon RX580. I don’t think that this can be an issue, but you never know :slight_smile:

May be related, I noticed the lack of latency info in Arturia 's recent VST3

1 Like

No, I don’t think it’s an hardware problem but the OS may be involved.
I’m also on Win 11. I believe I noticed an improvement in Win 11 memory management but I’ve experienced crashes with Analog Lab in the passed year but not lately.

I’ll try to reproduce the conditions that lead to malfunctions.

1 Like

I have another issue now that I remember, when I open Analog Lab in standalone mode, and begin to browse presets using up/down arrow, after some movements, Analog Lab crashes. I’m sure this began to happen after I moved the content directory to my second disc.
Would you be so kind and check this one as well?

Sure, it may be related, since if there’s something wrong (or missing) in the core vst3 implementation, we can have any type of weird things, such as latency issues, leaks and so on, true.

Duplicating 16 tracks with Analog Lab and the same controller does not immediately lead to a crash but recording 8 bars on the first track leads to a crash in Cubase Elements (16 gig ram).

In Reaper, recording on two tracks of 16 duplicated Analog Lab tracks did not lead to a crash or freeze but it sure slows things down. Reaper is suffering :woozy_face:

Maybe there’s a limit to the number of Analog lab tracks one can duplicate. This is a question for Arturia’s programmers.

I tried to replicate the crash I experienced which I tought was caused by a channel conflict between AL (there’s a channel setting in AL for Multi instruments) and Cubase. I did not experience any crash yet. But I did experience some crashes or freezes in the past months. In standalone also, if I remember well.

That’s a big one to test :hushed:
I would have to move the AL library to my second drive (a WD Caviar). Windows 11 is on a 1 tb 890 Evo ssd along with most of my music programs and their data.

I think you have good questions for Arturia’s technical team.

Ah, no, my request was just to check if key up/down in the presets browser, crashes the standalone Analog Lab, not in any way try to reproduce it by moving content :slight_smile:

Yes, I will contact them immediately!

1 Like

I’ve tested this on my system (Win 10 22H2), and while I never got as far as crashing, it appeared that the GUI was insanely slow when I added 16 instances to an empty project – including the base Cubase GUI.

Then I disabled multi-core processing for Analog Lab, and then set the Interface to 100%, and the default window to Main. This appeared to help a little, but still not really good to work with.

As I kept working on it - opening each of the instances GUI windows and setting each to a different preset, suddenly the Cubase GUI became responsive and relatively normal. It’s almost like a background process had finished (I’ve experienced something similar before with some instruments’ preset database updates). Or was it the fact that not all the instances were on the same preset anymore?

And then I tested browsing the library in the standalone version (Analog Lab Pro in list mode with the up and down arrow keys and it seemed fine. Apparently I currently have 13985 presets - even before adding a few of the newer free one’s.

And just now I finished recording a little 4 bar loop in Cubase 13.0.21 for all 16 tracks, each with a different preset, but no plugin GUI open. It all seemed normal without noticing anything weird.

1 Like

Hi Nico5, nice to see you here as well!

I followed all your steps, however things stayed the same. I wasn’t too optimistic anyway, since this thing happens both on win10/11 and mac os for me :frowning:

I even tried installing previous versions if AL, the issue remained, though I didn’t find much older installers.

The weird thing is that in Studio1 (4) everything works as expected.

On the other hand, on Cubase 11 I do recall a very stable behavior too, but now I get the same freezes.

On my Mac, no problem at all, and same goes for one of my PCs with Win10. The problem is with my main PC for music (Win11) in which I’ve installed all content to a D drive.

Oh well, I think it’s time to raise a ticket.