Analog Lab always playing at the same time as other instruments

Hi community,

I just set up FL Studio and my KEYLAB Essential 49 MKIII today (WIN 10 btw.)
I was able to assign all knobs and faders and got it to work with Analog Lab V as a VST3 in FL Studio.

However I noticed that everytime that I have an instance of Analog Lab open and switch to any other instrument (for example a Kick Drum) it would play the synth in addition to the kick. I do not have this problem with other synths.
You can see in the screenshot attached that I’m clearley focused on the channel with the kick but it always plays the Analog Lab instrument at the same time.

When I use my keyboard to play notes it does not do that and plays only the instrument that I focus. So it must have to do with the keyboard setup.

I appreciate any help!
Best, Navym

Hi @navym. Wlecome to the community.

I don’t use FL Studio.

Analog Lab like other instrument plugins only play if midi notes is sent to it.
Analog Lab is by defaukt set to recieve on all midi channels in the settings. So if the track is armed or something in someway is sending midi channels to it no matter on which midi channel, then it will play having this setting.
I can imagine your issue somehow have to do with this.

Does FL Studio have a midi indicator, that can show you if midi is sent to Analog Lab?

Hi @LBH,
thanks for your response. I will link a video to show you what it looks like.
Btw. I have the latest FL Version + the latest firmware for the Arturia Keyboard.

What you can see in the video is that I have linked my Arturia Keyboard to midi channel 10.
I can play Drums with a keystroke and as soon as I load an instance of Analog Lab I can also play notes in there. I can even swap between the different instruments with no problems at all. But I can’t use knobs, faders or the mod wheels unless I root the instrument to midi channel 10.

As soon as I do that you can see that I am able to use all the knobs etc. However that leads to the problem that no matter what instrument I play - the Analog Lab instrument is played at the same time.
Why do I want to root it to channel 10? Because Arturia themself stated in their video that this is needed in order to control the plugin.

My video:

Hi again @navym .

Traditionally midi channel 10 have been used for drums. I think that’s why Arturia mention channel 10, as it seem to be working working with a Drum rack using the controllers pads that’s by default is set to channel 10.

To me it look like Analog Lab is set to recieve on midi channel 10 no matter it’s in focus or not. I would say there should be a way in FL Studios Racks to tell if a instrument only shall play when it’s in focus.
Perhaps it’s about the settings you can see in the popup menu in the video you posted at 3:58.

Thank you @LBH, I’ve tried a few more things and couldn’t find a solution so far.
I will try to look up midi foucs or something.

Best, Navym

Hi @LBH I actually found 2 videos that show the exact same problem that I am facing. But both of them say that you have to reset or change the midi channel on the instrument in order to not be played at the same time. At min 4:

It also seems that this is a 3 year old problem which defeats the whole purpose of being able to control the plugin without a mouse…
I will reach out to FL Studio and Arturia support as I haven’t found a fix for this.

Hi @navym ,

I have not had time to watch the video. But if it’s about changing midi channel in Analog Lab, thenn you do it in the Settings in the right panel. As said, then it’s set to ALL by default.

EDIT: I’ve seen the video around 4 min now.

He say it’s a FL Studio thing. But i’m not sure it’s a thing at all. Perhpas he just don’t know how things can work.
It’s possible he don’t know how to set midi channels in Analog Lab. I assume you know about the right panel in Analog Lab. Otherwise feel free to ask further.

I can’t see this is an issue for Arturia technical support. EDIT END

Hi @navym ,

This video popped up in my Youtube feed: Arturia KeyLab Essential FL Studio Setup | The BEST Drum Pad Workflow No FPC
after 7:05 i hit a part where Analog Lab is triggered and it does’nt sound when other channels are triggered. So it is possible.

1 Like

Yeah just to endorse what LBH has said, it seems the video poster doesn’t realise midi channels can be changed in Analog Lab. That’s the easiest fix.

Hi thanks for looking further into it @LBH and @Jon_Vincent!

I was playing around with my settings for a few more hours and managed to bypass the issue that I initially had. I changed the midi settings within Analog Lab at the gear icon on the top right side within the plugin.

If its set to channel 10 I can make use of all the knobs, faders and mod wheels on the keyboard but I have the issue that Analog Lab plays along with other instruments.

If its set to channel 1 I bypass the issue but can’t control the modwheels anymore.

Any other midichannel in between does not work (as I cant hear anything played on the keyboard). So I am able to bypass the issue but at the cost of losing modwheel usability.

Again @navym - i don’t know how FL Studie work.
But if it require you send keyboard data on midi channel 10 for that instrument rack, then you need to make sure it does.
If we talk about Arturia Keylab Essential MK3 then probably set the keyboard midi channel to send on midi channel 10, as i think the controls are set to send on the global keyboard midi channel by default.
Some DAW’s can recieve on one midi channel and pass the data on another.

I can’t test. But try it out.