Yet another Polybrute Connect connection issues thread

Greetings everyone,

I’m aware that Polybrute Connect has issues with establishing connection with the hardware. I want to add my own experience to the reported instances.

I own a Polybrute 6. Polybrute Connect works in standalone mode, but not in the two DAWs that I own - Cubase 13 Pro and Ableton Live 11 on Windows 11 Pro. Polybrute Connect just doesn’t track changes in the hardware in my DAW and can’t send any non-MIDI messages to the hardware either. The Polybrute is on the latest firmware. The Polybrute Connect is also updated to the latest version as well.

Things I’ve tried:

  • No hub, powered hub - it doesn’t matter.
  • Cable length - I tried cables of various length, ranging from 1 meter to 3 meters, with our without USB cable repeaters. No luck.
  • Type A or Type C - this doesn’t matter either.

This behavior is very persistent and as I said before it happens in both DAWs, so it’s not a connection issue. Also the fact that this behavior is limited to the DAW instance but not the standalone app tells me this is a bug in Polybrute Connect that messes up non-MIDI messages to be received and sent in the VST instance.

Any ideas, anyone? My experience with the Polybrute Connect has been unjoyful, to say the least. Polybrute Connect was one of the selling points of the Polybrute ecosystem and here I am just spending time on trying to fix it.