Why does turning off Local keyboard also turn off the Local knobs?

This is horrible design, Ive never seen it done like this

why dont you have a separate control to turn the Local knobs ON or OFF as well?

for some reason I have to filter out all CC to the Minifreak when sequencing from an MPC, otherwise the “all stop” command causes the Minifreak to lock up and I have to hard reset it a few times before it will start producing sound again… but apparently filtering out the CC data to the Minifreak does not cause this issue, but then I cant edit the Minifreak patch from the panel because you have to enable the MIDI channel and monitor the MIDI in order to continue editing the patch from the front panel?

its just a horrible design for using this synth with MIDI in any capacity, but ESPECIALLY as a MIDI controller…

its like Arturia decided nobody would use it as a MIDI controller, so they just totally half-assed this part of the keyboard and made it basically unusable… it has so many bugs … wtf

Hi @rajajuju

You’ll be pleased to hear THERE IS a way to do this!

It’s in The MiniFreak Manual Page 110/120.


1 Like

you dont understand what im saying

the knobs only work to control the synth when “Local” control is set to “On”

otherwise the knobs will not edit the synth, and you cannot use any knobs to control any parameters

Sending CC to External MIDI has nothing to do with it… i need the knobs to control the INTERNAL ENGINE not send EXTERNAL MIDI

its a boneheaded design , and they need to fix it

Most synths I’ve ever used you turn off local control - then in order to still use the local controls to play the synth you loop those MIDI data back to the synth. As an example, to record the mF (in Reaper in this instance but conceptually the same in ProTools) I turn off local control on the mF, arm the track in Reaper and choose to record MIDI on that track, then in the hardware output of that track I send that MIDI back to the mF. A second Reaper track then records the audio output. Works like a charm, and any knob or control that sends MIDI (which on the mF is almost everything) still affects the “local” synth.


Thats a fascinating story Mike but it doesnt solve the Minifreaks problem with this lack of functionality

Also it wouldnt be an issue if the Minifreak didnt bugout and stop responding completely whenever it recieves a “stop/reset” command

The only way to prevent this is to filter incoming CC messages - so as long as its connected to my MPC its not able to recieve CC messages, because it glitches out whenever you hit stop twice (to reset back to the beginning of the sequence) … and im not sure why exactly, because it works fine from Ableton using a PC. But I have multiple other external synths connected to the MPC without any problems, so the Minifreak is the only one having issues

Anyways I would rather have the functionality of being able to turn the local panel controls ON or OFF as well as the option to send MIDI or not

also an option to turn off incoming CC from the Minifreak would be helpful as well

Yeh so anyways, the workaround Im using is to just stay on the screen to turn Local ON or OFF… and im constantly turning it on and off, so i can use the midi… then later so i can tweak the sound while the sequencer is running, etc

but yeh - it would be ideal to fix that bug on the “MIDI stop/reset” command

and it would also be ideal to have a feature where you are able to keep the front panel connected to the engine while the keyboard is controlling only external MIDI

I have already complained about the local on/off problem. Strangely, Arturia doesn’t want to understand the problem.

yeh its annoying me still

because i want to use the keyboard as a MIDI controller + and live synth at the same time

and this setting prevents this - i know plenty of actual artists and performers understand it clearly as well as i do

but the Arturia engineers dont seem to get it, or they dont care… which is truly unfortunate

on a side note… whatever bug/freakout was happening from “stop/reset” commands was actually caused by my MIDI interface… because after the latest firmware update, that problem is no longer happening

which is good - sorry for blaming you Arturia

but you still made a totally boneheaded decision about this local control thing

its really pretty simple, guys