Volca and beatstep pro/ did you have this devices and how did you set?

there is many topic for connect volca and bsp and many wyse advice of people who don’t have and use them …
if you have volca and bsp can you explain clearly your setup and midi configuration please?

Hi @kit welcome to our community!

I found a video in youtube that explain it, most of it I think.

But to be more precise, BSP have one midi out so the other outs you have to connect to your Volcas is the CV outputs (Pitch, Velo, Gate).

I hope this will help you…See you around! :smiley:


… that what i said before … a post by people who don’t have the device.
the first intention is full off kindness, but it’s not the request .

better ask may be ;who have volca and beatstep pro connected and functionnal?

Hi @kit,

Ok no problem. I have a volca and Beastep pro, but It is not to difficult to connect each other, I think but I can be wrong and the video explain well and have the two machines. But again, I have the machines, what do you need to know?

1 Like

You have a sexy voice, señor Fernandez, :star_struck:

It sounds good.
Beyond rhat, I use BST Pro with the Matrixbrute with Drumbeat ()drum channel or simple time midi clsock and the bass track to MatrixBrute.
The BST is slaved to Keystep37.

Hope you’ll get more more technically pertinent feedback.

Hi @francoise !

Sorry to say this but I’m not the person on the video :frowning: jaja It is just a great video I found on youtube but I think it works :smiley:

Nice that you use de BST pro! Yes of course here we can add more tchnically feedback :smiley:

1 Like

Hello !

I use my Volca Bass & Sample along with a BeatStepPro and it works great !

Here is my setup (note that a “Mixette” as it is written is a little mixer, that’s some french, sorry )


The things you must know (probably that @VFertorandez videos is explaining it but I didn’t watched it) is that there is a very specific way of using the Volca Sample in midi.

So any Volca’s will need one midi channel for itself.
The Volca Sample tho needs one midi channel per sample. Fortunately, the Drum track of the BeatStepPro can be configured to do so, one pad will trig one midi channel.

Besides that, there is no other things to know, it should work pretty much straightforward if you do setup your midi channels correctly.

Here is the MidiControlCenter settings for the drum map of a BSP configured to be used with a Volca Sample:

Hope it helps !



Hi . Maybe ther is something wrong on my parameter . I’ve try this soluce but it work once time and all was lost when i connecr other device .

  • First what is the global parameter of the volca ? Factory or modified?
    .Need specific firm ware ?
    .Does it work without midi quadra?. For one volca ?
    For the beatstep just change the device parameter as in video or ther is other ? Assignement pad ?

I’ve try this to… something is missing but i don’t see what . I’ve got once time the volca sound whith little delay time after try pajen ( firmware.all the volca have a pad responce But nothing after reconnect the other device.

The device setup have some specific rule to program the beat steep ? Just store to or automatic ?

Unfortunately my laptop choose to died this morning after i see your post …

Hi VFertorandez,

it crossed my mind but I thought there still may be some place for humor in this world :sunglasses:.

1 Like

Hi @Tim.Arturia !

Thanks for sharing that! I think it is the best explanation for that :smiley:

All my Volca’s use the latests firmware.

I think I’m using a majority of factory settings, but I may have change the PPQ settings, I’m not sure, I will check my settings when I can and get back to you.

It do works without the splitter, but not in my setup as I had to filter some midi messages to get everything worked perfectly.
Same, I will let you know the Midi Messages that I filtered when I can.

I will try without the splitter too but I’m sure it works well.

1 Like

hello all . i’ve finish to found what was the mistake . it was the adaptator midi arturia .
some latency keep going ,but it was not the device set up. thanks for your help.

tim.arturia :a force de chercher je suis même tomber sur ton post d’origine .


Ah yes I forgot to mention that you need to be careful about Midi DIN-TRS adapters. There is two different types, A and B. (and maybe more that I don’t know ?)

At Arturia we use B type.

I personally got theses cables for my setup => Befaco TRS-MIDI Cable B – Thomann France

@kit Aha effectivement tes pas le premier à galérer un peu avec ça. Au moins maintenant l’info est aussi ici en anglais histoire de faire profiter un peu la communauté anglophone.