USB MIDI to Gate out

This is driving me crazy, hope someone can help me.
Arturia support says that Keylab 49 MK ii supports USB MIDI to Gate out.
But I cant get it to work.
I connect a cable from keylab Gate out to an analog sequencer “step in”, and when I play the keyboard on Keylab it sends gate to the sequncer correctly.
But how do I do to get the DAW Studio Ones notes to trigger the gate out on Keylab?
I want to start the song in Studio One and get a gate out from keylab that corresponding to the tempo in the DAW.

Hi @Nimrod. Welcome to the community.

I don’t have a Arturia controller or work with CV.

But perhaps the informations you are missing is in the Keylab MK2 manual section
"2.14.2. Pitch/Gate/Mod Outputs
These four connectors enable the KeyLab MkII to interface with a modular synthesis
system. The voltage ranges may be defined in User Edit mode [p.47] or by using the MIDI
Control Center [p.65].
USB to CV : The KeyLab MkII can convert to CV any MIDI message received from the USB.
The MIDI Channel and the MIDI CC to be used for Mod1 and Mod2 may be defined in User
Edit mode or by using the MIDI Control Center."

When i look in Arturia Midi Control Center, then i can see it’s possible to select MIDI as MOD CV Source for Modulation CV 1 and 2.
In my head the rest should be about using Studio One including having the correct setups that’s needed to make the communication work.

Hope this is a help.

1 Like

Thank you LBH for trying to help me.
I have done those settings that you refer to, and from the keyboard side everything works, it sends correct CV out and Gate out when I play the keyboard.
But when I have recorded midi information in Studio One in a MIDI Chanel there, , it want play back those notes to the Keylab and out through CV Gate.
Maybe it is some setting in Studio One but in that case I cant figure out what?
Keylab is correctly assigned as Mackie control and as a MIDI keyboard in Studio One.

Hi Nimrod,

I don’t know your setups in Studio One.

I would try to do this:
Apart from setting up your controller as Keyboard and and Control surface.
In Studio Ones Options/External devices i would create a NEW INSTRUMENT. That instrument should be your Keylab MK2 controller. Selct it in the SEND TO dropdown menu. Now this “instrument” should be available as in a tracks instrument select dropdown menu, so you can select it. Do that.
Now the midi should be send to your controller.

Again i have no idea if this will work.

(A controller setup in Studio One also have the SEND TO, but can’t be selected as target for a track.)


I solved it now. :smiley:
I forgot that I have to add Keylab as an instrument to.

Edit: At the same time you wrote the solution. :sweat_smile:

1 Like

Good, just posted about that.
Thanks for reporting back.

1 Like

Unfortunately I discovered another problem.
Keylab skip some notes to be played.
If I make a part in Studio One with a note every eight, it plays most of them, but some random notes want be played?

Sorry to hear about that, just as we where happy it seemed to work.

Did you check the Sync boxes when you did your Instruments setup in Studio One? I can’t see it should matter in this case, but worth a try if not.

Also if you allready have your controller setup as send to in your controller setup, then perhaps delete the send to setup for the controller setup. Just to check if there somehow perhaps can be a midi conflict going on.

I don’t know, if some latency correction can help.

I can’t tell, if the controllers MIDI to CV conversion does’nt work correct. You’ll have to ask Arturia Technical Support about that, in case nothing of the above helps.

1 Like

OK, solved it now finally. :smiley:
If I remove Keylab as Mackie Control from Studio One the problem is gone.
Keylab as Instrument and as Keyboard at the same time is OK. But not when add Mackie Control.

1 Like

Thanks for reporting back Nimrod. Good there at least are a way you can use.

Apparantly there is a conflict somewhere.
But it make no sense to me, if you have to remove Mackie.
Are you having the issue when your controller are in USER mode?
Was your Mackie set up with both RECIEVE and SEND TO in Studio One?

It happens in both DAW mode and User Mode.
Both Recive and Send.

In your Keylab Instrument setup you have also configured a recieve from. I would try to delete that and only use the Send To.
And perhaps only use Recieve From in the Keylab Keyboard controller set up.
Also try to deselect the Sync options in the Keylab Instrument setup. As said it should’nt matter, it was just in case.

You should be able to have both Recieve From and Send To configured for the Mackie setup. It can’t be right, if you can’t control the DAW from your controller while using CV, i would say.
You can try to delete the Send To from that as well, just to see what happens, if the above does’nt solve it.


Changing the mackie Control to only “Receive from” did also fix the problem.
So its “Send to” in Mackie control that makes the conlfict.
Thanks for you help LBH, now I can even use the controls on the Keylab. :slight_smile:

Glad i could help @Nimrod .

If you don’t need the DAW to send Mackie messages to your controller, then this solution is fine if it works.

BTW: I saw you had a Jupiter-4 in your setups. I had a Roland Jupiter-4 once. Took some effort to keep the OSC’s tuned. Performance controls were great. Insane fast LFO. It could do lot’s of good stuff. I hope you make good use of it.