Registration & Activation Problems

What is going on with Arturia? This afternoon Arturia sent me some emails saying I am now registered with them so I download the software and activated it via the Arturia Software Center all the software was working and activated, I used the Analog Lab to play around with the instruments for a while I then closed down my PC for a couple of hours then came back in to the Arturai software center and it said I was NOT registered and all the software is now in demo mode, so I tried to re-register and it wouldn’t let me, the same as before Arturia fixed it.
I also went on to my account and it said I had nothing registered with them either. Does anyone know what is going on please.


Hi @Len56 and welcome to our Sound Explorers community!

really sorry to read this, in order to help you better please log in to your account to contact our support team that will help you to fix this situation.

Best :zap:

It’s the weekend so please be a little patient, I understand your frustration though!

If you haven’t already, Please make sure to subscribe to our Newsletter to be the first to know about any new and exciting news from Arturia.


The problem is I have already contacted support 2 days ago and they fixed the problem today then after a couple of hours the registration and activation disappeared.

I bought the Keyboard from Anderton music it was what they called B Stock so that means it was bought by someone else and they registered the software and then sent the keyboard back but they didn’t de-register the software so support had to fix. I just don’t know what is going on.

Hi again @Len56

Ok, I’ll try and escalate your case for you with support but, as I said, it’s the weekend so I doubt anything can be done until next week.

They should be able to resolve properly for you.

Hi, I’ve had a email back from support saying they have re-registered my product back to my account, I went into the Arturia software centre and the registration was back all I had to do was re activate products, at this moment in time it is working. One thing support did say that I de registered and deactivated my products, but I didn’t.