Recording in Logic Pro X - Arturia KeyStep 37 Low Volume

So when I try to play with my other tracks in a project, I can hardly hear the Keyboard. The other tracks are loud compared to the Keyboard. I tried the usual, lowering the other tracks but I can’t get them low enough, in order for me to hear the keyboard. Using Logic with Onyx Producer 2/2 audio interface. Using the mix knob doesn’t actually work. Whichever way I turn, The keyboard follows same volume. Hard to explain. No independent volume for keyboard. When I turn the mix knob on my audio interface, there is no separation of the track and keyboard. It’s in the mix when I’m recording that I can’t hear the Keyboard loud enough. This happens when laying down a track. Thanks in advance.

Hi. Is this exclusively an Arturia plugin problem or does it happen with Logics built in plugins?

1 Like

Only with Arturia. Never had This issue before. This is my first midi controller keyboard. At first I could not get the Sequencer to work as I had the dip switches on back of the keyboard set to USB… I switched them to Internal and now that works… It’s as if it’s not separating the playback of the keyboard on my audio interface . So using the mix knob only makes the keyboard and the track the same volume and I can’t separate the 2 with the mix knob in order to get a good mix balance in my headphones… I’m going to buy 2 midi cables and plug the artiuria keyboard into the back of my audio interface and see if that gives me a separate mix on my audio interface. I have never any problem as I have this setup for many years. IMO, the Arturia manual is terrible.

OK. To be honest I dont understand the problem. It seems to be related to track volumes and I cannot see how this can be caused by the MIDI controller. I will leave others more versed in this to assist. Good luck.

1 Like

Hi @Dino1956. Welcome to the community.

Your controller do not send out audio. The mix knob on your audio interface is probably some kind of direct monitoring mix knob. It only work with audio input - not with midi input. You audio interface can not control the volume of a single instrument among other playing intruments.

Like @Funtmaster assume, then i also assume it’s a track volume issue in some way. A plugin in a DAW send out audio to your soundcard. Many plugins have presets that’s set very load, probably as some misleading think that sound better, but often you actually need to lower their level. You can find loud presets in Arturias instruments, but they are mostly set at a more proper level. The level setting is done in the instruments and using the instrument track volumes in the DAW.

Some sounds in plugins can sound more quiet than others. But it’s still about leveling the sounds.

1 Like

I totally get what you’re saying. Yes some Plugins like the ones I tend to use like Mellotrons and piano are soft sounding. I’ve been using this setup for years with audio and I could always adjust the mix knob so that what I was tracking I would set it to be a bit louder than the tracks already recorded in the mix that I was playing to. My audio interface does have midi in and midi out. Do you think if I connected the midi out and in from the Keystep 37 directly into my Onyx audio interface, I could have more control of the mix?

Hi again @Dino1956 ,


Your controller can adjust the volume of the DAW track or of the plugin itself. You can also adjust the levels manually in the DAW.

I think you either remember wrong, or your audio interface mix knob in the past was’nt all the way to the DAW output side, if that matters at all. You adjust the level of all tracks playing with your audio interface. Your audio interface can not control individual tracks separately.

1 Like

Thank you. I am totally new to midi as you probably guessed. So the keyboard is just a means of playing a Plug In. A mere shell if you will. Now I get it. I received this for my Birthday which was yesterday. I had the dip switches on Keyboard set to USB, since I was plugging it into my iMac. But the sequencer did not work. The famous company I purchased it from, Tech Support guy could not help me figure it out, so they are sending me a replacement keyboard tomorrow. But after I switched the dins on keyboard to Internal, the sequencer started working. Both the tech guy and I assumed USB was the way to go. So I figured that part out on my own and now it’s all working. Question: Would there be any advantage in connecting 2 midi cables from keyboard to my audio interface and would I have to toggle the din switch to a different setting? I’m guessing I would still need to plug the keyboard in my iMac via USB. I’m sorry if these sound like ignorant questions. I just simply do not know. Thank you for all of your help and quick replies. I do appreciate it.

Sorry for repeating myself. Thank you.

That’s fine. We all need to learn. Do not exspect to learn everything in a second. Exspect to use time to study and test.

You should use USB connection.

The DIN MIDI connections on your audio interface can be used, if you for example use outboard gear with no USB.

1 Like

Thank you. Guess I bought those midi cables for a later use. Really thank you LBH! Although tech guy on phone did his best, he did not explain any of this. Thanks for your patience and time. All the best! I am reading the manual. Not a fan of this manual. They leave out parts. They need to be more detailed for new users. I’ve read a few manuals in my time but this one was not very helpful. At least to me. But I am still reading it trying to get more out of it. Worse scenario, I will lay Keyboard tracks down early with Bass & Drums, so the mix will not be so loud.