Polyphonic Aftertouch in Ableton Live

Hello there,

I’m trying to use the Polyphonic Aftertouch feature when using Pigments as a VST plug-in in Ableton Live 12 and controlled by a CME XKey MIDI Keyboard. As you can see in the image attached the track is receiving pressure data from the keyboard but the AT is not being affected by it.

When using Pigments in stand alone mode everything works fine, so perhaps it’s only a matter of finding the right settings.

I would appreciate your help!

Thanks much,


It is working for me with Live 11 (I haven’t installed 12 yet) and Push 3.

There is a MPE mode setting for plug-ins in Live. For me, it was on by default when I added Pigments to the track. If it isn’t for you, it can be turned on by right-clicking (or control-clicking) the device title bar.

There is also a setting for enabling MPE in Pigments, which was disabled by default for me. It was showing (monophonic) aftertouch even with that disabled, so that may be a difference in the way Push 3 handles pressure vs. the XKey.

I’ve highlighted the settings with orange boxes in this screen shot:

Thanks for your answer. I tried to follow your instructions but it still doesn’t work. There is a difference between our setups though because XKey sends PolyAT and Push 3 sends MPE which are not the same thing.

When I enable MPE for the XKey in Ableton’s MIDI settings I no longer see the incoming changing pressure (see image below).

In any case I tried both options, i.e. enabling/disabling MPE (in Live’s MIDI settings, on the plug-in instance in the track and inside the VST itself) but neither seems to work unfortunately.