PolyBrute doesn't boot after 3.0 update crash

Hi, I just tried to update my PolyBrute to v3.0 via PolyBrute Connect. But the update process got stucked and the PolyBrute Connect software (Mac) crashed. Now, I can’t boot the PolyBrute anymore! When I switch it on I just the Poly LED on the top left corner lights up, nothing else.
How can I make it work again? Is there a sort of hardware reset?
Thanks for your help!

1 Like

Hi @flonky welcome to our Sound Explorers community

Sorry to read this, in order to help you better please log in to your account to contact our support team that will help you to fix this situation.

Best :zap:

I have the same problem …

did you solve the problem ?

There is no hardware reset to my knowledge.
Did you update Polybrute Connect to 3.0 before updating the Polybrute firmware ?

Anyway I would suggest you to try again. Maybe with another computer.
It took a long time for me to update the firmware to 3.0 (like 10 - 15 min).

Hi, I have the same problem, my Polybrute is like “dead” only the small led ‘poly’ near Polyphony label at the top left . How ? I tried to update to the 3.02, with connect 3. and I got several(20, 30 times) failed, and finally the Polybrute was like “dead” ? How is this possible ? not even a rom with a basic OS in case, nothing ? not a very small ram with a little batterie in case(we are talking about 1,3 meg) ? come on Arturia, so when one tries to update his expensive baby, one does not realise he could kill the complete system if anything fails ??? I can’t believe it’s that bad…

HI @philthebeat @Michael_G @FreMer @flonky

Sorry to hear this is still ongoing, there IS a factory reset option for The PolyBrute, but unfortunately it’s in the Global/Misc section, (P98 in The Manual) which of course, requires the unit to be powered up an on. I’m not sure if there is a ‘mechanical’ option though.
I’ll try and escalate this, but obviously it’s holiday time in many parts of The World currently, so it won’t be in the next few days.

Hi, thanks for your answer, but for me this is not an option, because when turning my Polybrute on, I only get a small light on the left top corner, no more screen, nothing…
Anyway, thanks again and by the way… Merry Christmas

It’s not that bad :slight_smile:

It appears that yours is starting bootloader mode:

If you power up the PB while holding the Polyphony button, it starts up in bootloader mode, ready to receive a firmware update. When in bootloader mode, only the “Poly” LED is lit.

You could try starting it explicitly in bootloader mode. If no firmware update is possible then, things could point to something not in the PolyBrute but earlier in the chain (USB cable, USB port, MiniFreak V…). You could t try changing cable and/or ports. If it still doesn’t update, it’s probably best to wait to hear what support has to say.

Merry Christmas! (even if a day or two late :-D)

1 Like