Pigments - Error message - What do I do?

Whether I use Pigments in my Logic Pro X as a plugin or a standalone, I get the same error message.

What do I do to fix this. I tried doing the Reinstall feature. That didn’t help.

HI @paulold and welcome to our Sound Explorers community!

Did you just reinstall without uninstalling first?
Do you have your Arturia content folder on a different drive to your system drive?

If not, try uninstalling first, restart your machine and then install again.
Let us know how you get on, if it doesn’t work, there are a couple of other things i can think of, best to work through it logically first though.


If you haven’t already, p lease make sure to subscribe to our Newsletter to be the first to know about all the latest news from Arturia.

When I first tried to fix it, I tried reinstall. Then I tried Uninstall and Install. I did not restart. So I restarted my laptop, uninstalled, restarted my laptop, Installed, restarted my laptop and no luck. Still getting the same error message. I am using an external SSD drive to save space on my internal hard drive. When I check the preferences, it appears the path is correct. Now what should I try?

Hi again @paulold
I had a similar error once, i also keep my Arturia resources folder on a different drive to my system drive.
I managed to ‘trick’ ASC by clicking ‘Reset’ in the ‘Folders’ tab in ASC and then browsing back to the actual location.

If that does not work, i can think of one thing more.
That would be to uninstall again, then go through the Arturia system folder and remove any trace of Pigments manually, restart your machine and then install again.
If these options do not work, please report back to let us know and the contact support.

@matjones Thanks for the help! Resetting the folder in ASC didn’t work for me. So I tried to uninstall. I had to restart before I could get the uninstall to work though. And then I looked for anything Arturia-related to remove from my folders. Of course this means I deleted ASC as well. Oops. But after emptying my trash and restarting again, I installed ASC and then installed Pigments. I again put Pigments on my external drive but this time I chose to create the Arturia folder in the Library folder on my external drive. Last time I used the Music folder. Not sure if that made a difference, but the reinstall worked and I was able to get both the plugin and the standalone Pigments to work without an error. Thanks again!

1 Like

Hi again @paulold
That’s great news! Glad ‘something’ helped get you back up and running! :sunglasses:

We’ll mark this as ‘solved’ then.

Was this on OSX? I am not an expert but have had enough issues with other software to suspect that this is a permissions issue. The Library folder may have enhanced permissions as a system folder whereas the Music folder (probably in the User folder) may have lesser permissions. It’s only a guess and maybe my gibberish may make sense to someone who understands better than me.