No more screen after upgrading the firmware to v2?

Is there any manual reset I could try ?

Or revert with previous firmware ?

I tried to reinstall the firmware.

Power down + power up pressing shift and ← octave

This allowed me to reinstall the firmware

And now everything seems ok.

4 Likes

Hi @artakan and welcome to The Sound Explorers Forum.

Great to see you figured it out yourself, I do believe your experience is fairly normal from what I know.

Ps,
Please make sure to subscribe to our Newsletter to be the first to know about the latest from Arturia.

My is stuck! Just the “MiniFreak Algorithmic Synthisiyer” and stars moving from the bottom to the top of the screen. :frowning:

Yes I spoke too fast, now I have the same as @kordics, the installer said I had to wait one minute, but the synth got stuck, I even waited 5 minutes, and now I only see stars moving…

The Boot Loader mode is not accessible any more
@matjones any last resort trick in that case ?

1 Like

Hi @kordics and @artakan

I’ve not had time to update my own MiniFreak yet, but I’ve been told by one or two others that they had to perform the firmware update/restart a couple of times or so to get it working properly. That’s the extent of my own knowledge at the moment.

1 Like

Hi @matjones !

How do you perform firmware update reset? At the moment when I start MiniFreak V, I cannot link it to the MiniFreak. Is there any other way?

1 Like

Hi @kordics
Do you mean rolling back the firmware to the previous version? I’m not sure this is possible.
If you mean what to do after updating the firmware, generally you should restart the device if it doesn’t restart itself.
Is your MFV refusing to connect with your MF hardware?

@matjones , thanks for the replay!

After updating and witing for 10 minutes, I have restarted my MF. Since then, MF is showing only “Mini Freak…” and the moving stars on the screen. MFV does not show any option for linking to the MF or update options. So, I cannot reach MF in any way. Anyway, thank you for your asstance!

@kordics
Ok, sorry to hear this, thanks for letting us know!

I’d be inclined to message support, I think this might get picked up quickly.

1 Like

@matjones

Thanks for suggestion! I will certainly do that!

1 Like

Same issue here, request submitted

1 Like

Same for me too, bummer.

1 Like

Arturia support have send me their utility for v2.0 update, but unfortunately it didn’t solve the problem. My MF is not recognized by my computer, so I’m afraid that I have a big problem with it…

I had multiple failures to install the firmware. Kept saying “Successful Update” and then didn’t reboot. When I manually rebooted first two times it restarted and said it was using 2.0 firmware but there were weird problems (such as it going silent when I browsed to new sounds), so I tried again. Third time it couldn’t boot up at all (just showed the animated startup screen). I used the key sequence mentioned above by arktan to hard reboot and that let me have another go. Fourth attempt was successful and it auto-rebooted. I also switched to a direct USB cable from my laptop to the minifreak, whereas before the minifreak was connected through my Dell docking station. Don’t know if that made the difference.

2 Likes

Yes I also received their tool, but as I can’t start in boot mode any more, it’s useless. I was asked to send to repair, hopefully they will not charge us for this. This is really bad software is that’s so easy to brick …

1 Like

Same here. I have contacted Thomann, since I bought my MF from them for repair.

You guys have run into the same issues as I did when updating from V1.0 to V1.1. I bricked two Minifreaks at that time by switching the Minifreak itself off when the updater said it would reboot the Minifreak but didn’t. I did get the hard reset into boot mode trick from someone on the old forums, but in the end that didn’t get me any further (all update attempts ended in the incomplete update state) and I just got into the locked state that some of you are also experiencing.

I had my dealer swap the first one for a new one, but ran into the same issue with that one and finally had to send the second one to Arturia in France to have it fixed when that one invariably also ended in the locked mode.

Later they posted a recommendation that after the update was done (at least according to MiniFreak V), to close down the app or if that didn’t help, to reboot the PC.

I don’t know if this works (I got my Minifreak back updated to V1.1, so up to now no need to update). I’ve been reluctant to try the update process for fear of ending up in the same situation, so I waited to see what others are experiencing. Seems that the update process is still as loaded with boobytraps as it was with FW 1.0.

So if you have a bricked Minifreak, that no longer is able to get into update mode, the only solution is a return for repair to Arturia.

If you still have the option to get the Minifreak into boot mode, retry the update and if the Minifreak doesn’t reboot at the end, try the closing of Minifreak V and/or the PC reboot.

Please post here if one of those methods resolved the issue for you and lead to a successful update!

Here is a link to the topic I opened on the firmware update failure on the old forums:

2 Likes

I’m still on 1.0 because I like my MiniFreak too much to try and update. It’s really frustrating that Arturia seems more concerned with tossing out 1.x bricks and calling them major upgrades than they are with fixing the update process.

We’re just guinea pigs to them.

1 Like

This seems to be affecting a minority of users, I realise that’s not likely to be out much comfort to those that are affected though.
I updated my own MF yesterday via the standalone MFV and am up and running smoothly. I know of quite a few other users in the same position too.

It might be worth everyone experiencing issues posting their system specs to see if there’s a common link.

1 Like