No knobs and sliders of MiniLab 3 with Augmented PIANO in FL Studio

Hi there,

I have the weird problem that none of the knobs or sliders of my MiniLab 3 have any function when using AP from within FL Studio.

When attaching my Keylab MK 2, all works fine.
When controlling other instruments (like Analog Lab or pigments) both Keylab and Minilab work fine.

Weird thing is, these combinations work:
MiniLab 3 with Augmented PIANO standalone :white_check_mark:
MiniLab 3 with Augmented PIANO in Analog Lab in FL Studio :white_check_mark:
MiniLab 3 with Pigments in FL Studio :white_check_mark:
FL Key MK2 61 with Augmented PIANO standalone :white_check_mark:
FL Key MK2 61 with Augmented PIANO in FL Studio :white_check_mark:

The only combination that does NOT work:
MiniLab 3 with Augmented Piano in FL Studio :stop_sign:

I have tried on different machines, same result.

Anyone else having that problem?
Anything I can do about it (but waiting for Arturia to solve th problem)?


Hey @StefanS Hmmm it’s weird that your augmented piano doesn’t run with MiniLab3 on FL.

Have you tried to install/uninstall the Augmented Piano from the ASC? also, did you checked that you have installed the last firmware for ML3?, same for the last version of ASC.

Otherwise I strongly suggest you to log in to your account to contact our support team that could help you to find a solution based on your setup.

Best :zap:

Yes, I’ve done all this. Firmware is 1.1.1

And the issue is easy to reproduce:
I just installed everything fresh on a new machine, same issue.

I already opened a ticket with Arturia support.

Unfortunately, I only get answers of the quality like ‘make sure that all cables are connected’ (sorry for the sarcasm, but support-quality is really low).

So, I will wait patiently until hopefully someone from the support realizes that there seems to be a problem with the product, not my setup.


1 Like

Hi there,

in the last reply from Arturia Andres asked me to record a video to show the behaviour (he said he couldn’t reproduce it).
That’s strange, because we could reliably reproduce the phenomenon now on 5 different PCs with 2 different Minilab 3 keyboards!

I replied by asking what exactly they want to see on the video, so I can capture it accordingly. Would they really need a prove that I can turn knobs on my device and nothing is happening in Augmented PIANO? Don’t they believe me?
No answer.

For more than 3 weeks now, I even get no more answers on my mails to Arturia at all.

Does the company still exist?
Do they have any interest in supporting their loyal customers? :roll_eyes:

As much as I like the products, as poor the support seems to be. Quite sad.


Hi @StefanS
Sorry to hear you’re still having issues, that’s strange you’ve not heard back for a while, i’ll flag this up for you.
Unfortunately, there’s not much else i can do as it’s the weekend currently, so we’ll have to hang on until next week.

Thank you for engaging.

It’s not urgent, I can help myself by using AP standalone, when I want to modify the presets.

I just wanted to make sure it’s not forgotten.


Hi @StefanS ,

It is a strange issue.

According to your first post, then both Minilab 3 and Augmented Grand have you tried both Piano work in FL Studio. But they don’t work together in FL Studio.
It really make no sense.
And apparantly Arturia don’t have any issue.

When it don’t work, then i can think of two meanings.

  1. The GUI knobs does’nt move.
  2. The GUI knobs move, but it does’nt do anything.

I think Arturia perhaps ask for a video to see if it can help them to understand what’s going on, as it as said make no sense. What should go wrong between just the Minilab 3 and the application, when it works with another controller, if you are doing everything the same way with the same preset in the same project?

I don’t think it should matter, but have you tried both the Minilab 3 and the Generic setting in the MIDI tab in the Right panel of Augmented Grand Piano? It’s one setting i can see might be different, so it’s something to check out.

Good luck

Hi @LBH ,

thank you for trying to help.

As I said, I have tested all possible combinations I could think of (see my first post), ALL but just the one with Minilab & AP within FL Studio don’t. :man_shrugging:
Even Augmented Piano within FL Studio works with a KeyLab MK II (with rayjs’ script) and with a KeyLab Essential MK 3.

And yes, I have tried to ‘learn’ the knobs in the midi settings, nothing happens.
The knobs in the GUI don’t move, even FL Studio doesn’t seem to read any input via Midi (usually you can see the Midi values in the info-window).
With all other devices, turning a knob will show the corresponding input-values, only with MiniLab 3 and AP it shows nothing.

I agree, this does not make sense.

And: you can easily reproduce it.


I just tried the ‘generic’ Midi, no difference.


I don’t have or use FL Studio. I also don’t have a Minilab 3. So i can’t test it. And apparantly Arturia have tried it out, if they can’t reproduce the issue.

This make absolutely no sense at all.
You said Minilab does work with other applications inside FL Studio. So Minilab 3 must send data to FL Studio. How should an application obstruct incomming midi messages - i wonder.

Please keep in mind, that i’m not saying the problem is on your side. But it all really just make no sense. So it can take quite some time to figure out.

I can tell you, that i years ago had a strange issue. Nobody but me seemed to have the issue. I posted a video showing the issue to Arturia. After a long time they found the issue. The issue was far out to find, but Arturia did’nt give up, and they found and solved the issue. We can’t tell, if this issue is on Arturias side. Hopefully it will be solved somehow.

It would be nice and a help to find and solve the issue, if users using Minilab 3, FL Studio and Augmented Grand Piano could tell, if they have the issue or not.



Nobody but me seemed to have the issue.

That’s not the case here.
First I had the issue on my Surface Pro 7.
Then we tested on two different systems of my son with a different Minilab 3 - same issue.
Then on a new Surface Studio of mine - same issue.
Eventually on my sons’ new computer - same issue.

So I wonder how it can NOT be reproduced.

Any other reports about experiences with Augmented PIANO - Minilab 3 - FL Studio are welcome!

As I said: I will be happy to shoot a video, but I need to know what it shall capture. Just seeing me turning knobs on the Minilab and nothing happening in AP doesn’t deliver any new information.

BTW: before anyone asks: Midi input channel of ML3 in FL is set to 10. Otherwise it wouldn’t work with Keylab MK II or Essential either (which it does).

Hello @StefanS thanks for reporting and sharing your issue.

We’re sorry to read this.
Our team will get in contact with you shortly.

Please let us know how it goes.

Best :zap: