No Clock Detected - External Sync in Arp mode not working with DAW or Analog Lab

I am not able to get the Keylab Essential to receive a MIDI Clock via USB MIDI.
I tried with Logic and I tried using the standalone Analog Lab.
I keep getting the clock not detected error message. In Logic I’m fairly proficient, and I activated the sync options for the Keylab in the MIDI Sync settings, but when I try to start the song nothing happens with the arp and no clock gets detected.
Any help? For the rest, the Keylab is recognized in Logic and all the features seem to work.

Hi @fabxist . Welcome back.

Read the Keylab Essential MK3 manual section “ Sync”?
Are you sure you are sending a clock to the controller and do it correct? If so, then i suggest you contact Arturia support.

I did. The clock is set to Ext and Logic in Play mode is sending a clock signal to all MIDI ports. So I think the problem is that the USB MIDI input of the keyboard is not working as it should, as it doesn’t receive the clock signal.