New MiniLab 3 is no longer working after firmware update to 1.1.1

I have a problem with a new MiniLab 3 after installing the new Firmare update 1.1.1 to the controller. At the moment only the word ‘ARTURIA’ is displayed near to the main knob. Nothing else is working and no effects even when pressing knobs or pads…In the Midi Control Center Software there is displayed the correct version of the firmware (1.1.1).
Who can please help me? What can I do to solve this problem? I just created also a ticket in the support area…Many thanks in advance for any help!


Experiencing absolutely the same problem. Can anybody help?

1 Like

The same problem appears today
Yesterday all works fine, but this morning I connect minilab again to the notebook, and it shows only logo on minilab screen. No keys or knobs sending midi signal.

I’ve tried to reinstall midi control center and usb midi driver - and nothing takes effect :frowning:

@MagicJan1506 @k8ahj @Vasiliy_Bo Have you tried contacting Arturia Support in this link ?

Yesterday I’ve sent message, waiting for answer

Yes, I’ve already contacted the Arturia Support, but they had no solution except sending the device back to the reseller or to a technican of Arturia. In my case, I’ve sent the MiniLab 3 back to the reseller (Amazon).