New Keystep 37 User Questions ... Trying to get it working

I just received my Keystep 37 Black and am trying to get it installed and working. I believe I followed all the steps from the keystep37_start page but something still isn’t working. I have the MIDI CONTROL CENTER installed and have updated to the latest firmware ( I have it set to monitor MIDI channel 1, which I believe is the default channel used by the 37. With MCC open, it appears that my keypresses on the 37 are being recognized (see a small down arrow icon in the Device section header flashing green when I press a key (but I’m not seeing the release (up) icon flashing). I’m also seeing key messages displayed at the bottom of the MCC window and they appear to be matching the keys I’m pressing on the 37. Seems to be working. Is there a specific test I can do to see that I have MIDI communication between the 37 and my Windows laptop?

My goal at this point is just to be able to press keys and hear piano sounds (pretty simple). I have installed Analog Lab V Intro. I’ve selected the “American Home Grand” instrument but when I press keys on the 37 I get nothing. I’m not seeing the keypresses displayed nor do I hear anything. I do hear the Grand key sounds when I press the keys on the Analog Lab V Intro keyboard with my mouse. Guessing I’m doing something stupid, so if anyone can lend a hand I’d appreciate it. Thanks.

Hi @sealyons62 and welcome to The Sound Explorers Forum.

I’m not currently at my machine, so I can’t post screenshots, but I’ll try and talk you through it from memory.

Firstly, you don’t need MCC open to do this.
Connect your ks37 to your computer as normal and then open ALV Intro.
Click on the ‘hamburger icon’ in the top left of ALV (is the three small horizontal lines).
Select audio and midi options, select ks37 as your midi ports and if you have a dedicated audio interface, you should select that as the audio output device. If you don’t have a dedicated audio interface don’t worry about that for now, just leave the audio setting at its default.
You’ll also see an audio test button in this panel which you can click to make sure your audio output is configured.
Once you’ve done this you should be up and running.

If you’re still struggling tomorrow, I’ll post some screenshots when I’m back at my machine.


Please make sure to subscribe to our Newsletter to be the first to know about the latest from Arturia.

Hi, thanks. I go to ‘Audio MIDI Settings’ and set the MIDI ports option to ‘Arturia KeyStep 37’. But this appears to get deselected somehow because each time I come to this page it’s deselected. What should I do about that? Input channel is set to ‘Input Channel 1’, is that where I should leave it? With these settings set it doesn’t appear to be working. Is there anything I need to do in ALV to allow my 37 to control the on app keyboard and play sounds? Appreciate your help.

Hi @sealyons62

Ok, I’ll post some screenshots for you tomorrow when I’m at my machine, it’s pretty straight forward once you know where things are.
Meanwhile, feel free to explore the manuals for your ks37/ALV and you might stumble across the solution yourself.
I’ll check back with you tomorrow.

Ok. Thanks. Does what I described above make sense? Should the KS37 keep getting deselected each time I enter the Audio MIDI Settings page? Is there anything else I should set? I’ve attached a screen shot of what this dialog looks like each time I enter (the 37 shows as deselected).

I’ve looked through both the KS37 & the ALV manuals but am not seeing anything specific about how to get this working.

Hi @sealyons62

I see you’ve found exactly what I was going to post tomorrow, good stuff!

Do you have any other options for your audio driver and audio device by any chance?
Might be worth dropping your latency down to a lower value too if possible.

You say you’ve tried checking the box in the midi ports field and it won’t stay checked?

I select the KS37 in the MIDI settings window and the checkbox turns BLUE. I’m guessing that’s selected. It stays selected (BLUE) while I’m on the window and I press OK which closes the window. When I open it again, it’s NOT selected.

Remember, I can hear the instrument sounds when I press the displayed keyboard with my mouse in ALV. So that would indicate to me that the Sound Drive & Device are mapping to something that alliws sound generation.

Under Audio Driver, here are my options:

Windows Audio
Windows Audio (Exclusive Mode)
Windows Audio (Low Latency Mode)

I’ve not changed this, it has always been set to ‘Windows Audio’. Should I try something else?

Under Audio Device, the onky option I have is ‘Realtek(R) Audio’.

I don’t see a field for Latency. What do you mean?

Also the Test Audio Play button appears to work. I hear a tone when Play is selected.

I tested all the options for Audio Driver and none appear to allow playing of the KS37. But all, except ASIO, appear to be working since I can hear the tone when Test Audio Play is pressed.

I left the Audio Driver on ‘Windows Audio (Low Latency Mode)’ since it seems having lower latency would be beneficial. Still doesn’t work.

HI again @sealyons62
Ok, great, you’ve tried a few things i was going to suggest.
One thing i forgot to ask, are you using a USB hub at all with your KS37? Have you tried a different USB cable and different USB hub on your computer?
Also, your power scheme COULD be causing issues with this, are your USB ports set to always on?
You can check this by typing Computer management into the windows search box, click on the app that appears in the ‘most likely’ suggestion and you’ll be presented with something like this…

I’ve highlighted where to click in yellow.
You’ll need to right click the USB entries on the right hand side, not all of them will have power settings but check them all just in case.
You’ll be presented with the following box, click on the tab i’ve highlighted in yellow…
USB PWR management 2
and make sure none of the boxes are checked, uncheck them if they are.
I would then restart my machine, reboot and try again.


The buffer size in your screen capture is 512 and with a 512 size, the latency is 10 msec. but this is not your problem.
In the midi port option, Arturia Keystep is unselected. This is your problem. This can happen in Windows when the Keystep is already busy with another program (another instance of Analog Lab or Midi Control Center). You have to make sure Analog Lab is the only program running. If Analog Lab does not retain the Keystep as midi port option, I’m puzzled.

Still not working but I have some additional info. I installed Cakewalk DAW and it fully recognizes my KS37 and it’s working fine.

Although not the major problem, what should you set as the buffer size? Is that something you have to manually tweek? What’s the formula for calculating latency from buffer size? Won’t that change based on the processor speed? How are latency and buffer size related? Will having more latency lead to a perceived delay between pressing a key and hearing a sound? What is a target latency to shoot for to keep key presses appearing to emit sounds without delay?

I may have had both AL and MCC running at the same time. I’ll be sure AL is the only running app and see if that resolves the issue. Seems like AL & MCC should show a dialog warning users that they can’t have both running simultaneously if this will lead to AL not connecting to a MIDI Controller and not working.

Not using a hub. Have 2 USB ports on my laptop and have tried both, same result. Power doesn’t seem to be an issue, I use my machine for all types of external USB powering and have never had any issues. I’m away from my machine at the moment but will check settings to see if I see anything. I’ve also reached out to Arturia support. I’ll let you know what I find out later.

HI @sealyons62

Your buffer size, along with sample rate, will govern what latency you have.
So, if you have a smaller buffer size it will give you lower latency, your interface should have some kind of control panel for this, if not, try changing it from your DAW.
I notice you have an ASIO driver installed, this bypasses Windows audio and will generally give better performance so i’d select that one.
It’s strange that the standalone version of ALV will not work with your KS37 but your DAW does, i would definitely try running the standalone without MCC being open as it sounds like MCC might be ‘stealing’ the midi connection.

Ok, that worked. As long as I close any programs that are interfacing with the KS37, it seems to work using AL. Still think it’s odd that AL has this behavior if anything else is attached (including their program(s)). Still think they should tell you this directly in their programs. Would have reduced my frustration. Thanks all for the help.

Also see that the latency is given on the MIDI setup page after the stated buffer size.

1 Like

Hi @sealyons62

This isn’t uncommon behaviour really, i have several synths here that behave in exactly the same way.
At least you’re aware of this now so it shouldn’t be an issue for you in the future. :sunglasses: