Midi to type A/B

I want to play sounds from the Roland J6 on the Keystep 37 …the J6 only has a trs mini midi connection…Roland sucks…
I got an adaptor from China and it doesn’t work…??is it type A and do I need B…I ordered a B
from Sweetwater… what do you know??? and is there any way to just use USB to connect them?? I tried a USB connection between the 2 devices and it didn’t work… ridiculous…

USB is only a bus to carry messages – it requires a host in order for communication to work between devices. Often that USB host is your computer, hooked to a USB hub that allows multiple devices to be connected and receive messages. You can also buy a standalone MIDI hub. (Or for that matter, the new Audiofuse 16Rig that Arturia makes will function this way without being attached to a computer!) Hope this helps.

Hi @pan34 and welcome to our Sound Explorers Forum.

As @stickster above has pointed out, just connecting the USB port of one midi device to another won’t work, USB is not designed for this, MIDI is.
I have a couple of devices myself that use those rather odd, and frankly annoying, DIN to 3.5MM micro jack things, so i route the KS37 through my computer via USB and then out of the computer to the USB of the device i’m using.
It’s a shame that your ‘converter’ didn’t work, perhaps you could ask for a refund and purchase a higher quality one if you do not want a computer in the equation?

Ps,
Please make sure to subscribe to our Newsletter to be the first to know about the latest news from Arturia.

that sounds ok to me…can you elaborate…? is from the J6 chord mini module to my USB hub…
and then my Keystep 37 to the computer?? the K37 is already hooked to my computer hub
but not the Mac directly…walk me thru this please…

Hi @pan34

Let’s see if we can get you up and running!

The way I, and pretty much everyone else who uses a computer, do it, is to connect your KS37 to your computer with USB, make sure you have the Arturia software center (ASC) and midi control center installed before hand.
Then connect your J6 via USB to your computer, generally it’s a good idea to use a different USB port on your computer rather than a USB hub as hubs can be problematic.

I’m not sure if the J6 has it’s own driver, I have a couple of Roland boutiques and they’re both class compliant so don’t need one, you will need to check this.

Once they are both hooked up start your DAW software, create a new project or load the existing one you wish to work on and create a midi track with the KS37 as the input and the J6 as the output. Make sure the KS37, J6 and midi track in your DAW are all on the same midi channel and you should be up and running!

If you do not use DAW software I’m not too sure how you would go about this, possibly something like MIDIOX MIGHT be able to do the job for you. I do use midiox myself, but purely for analysing midi messages and as a sysex librarian.

HTH!

that would probably work.thanks. Or I can do an audio track and run the mixer out to my audio interface and do an analog track…but for just practicing I will use the type B adaptor
when it shows up here…

Hi @pan34

The method I described DOES work, it’s the way many of us approach the situation.
When you say ‘mixer’ I take it you mean a physical mixing board?
If so, depending on the quality of the mixer, you might be better off using the line inputs on your interface to record the signal from your J6 as I’ve found over the years that a less than stellar desk can introduce a fair bit of noise. I have a little 16 channel Soundcraft mixer here I use from time to time as I quite like the sound of the mic preamps. I’m lucky enough to own some more ‘high end’ units from some of the most respected studio preamp manufacturers and they are night and day noise wise.
I have to manually trim any’silent’ sections from anything I track via the mixer.
Obviously though, unless you’re using any ‘zero latency’ monitoring on your interface, if you monitor via your DAW it will be subject to latency.

Hopefully that clarifies your options a little more. :sunglasses:

well I got the type B connector and it still doesn’t work…??? is it something in the Midi Control Center…?? The Roland is transmitting on chan 1. What is going on???

HI @pan34

Ok, can you list EXACTLY how you’re setting up your hardware from the KS37 to the J6 please, let’s work through this logically, stage by stage rather than in little bits.
MIDI cables only have two cores and a shield, so there’s very little to go wrong and they’re pretty easy for anyone with a soldering iron to make in a few minutes, of course there’s always the possibility you’ve been unlucky and purchased two duff units.

Din to 3.5mm TRS pin configuration.

Do you have a basic multimeter/continuity tester that you could use on your midi converter to test them?
Might also be an idea to post a picture of the ones you purchased too.

We’ll get there!

I think at this point that its 98% likely that its in the K37 settings…so I think I need to know the correct settings on the midi control settings for the J6…right now my K37 works good in Cubase so its not faulty. But I think Cubase might assign some settings that it needs to function correctly and those settings are at odds for Roland products like the J6 mini chord module. I would think that the J6 would make the needed settings changes on its own but
no… what are the correct settings in the midi control center…?

here are my current settings
One thing I notice…the midi thru on the J6 is off…

I solved it. I found a video on YT by a guy with a thick Euro accent who showed how to take a simple coax red/white to 3.5 and just reverse the plugs…red to white-white to red. I have SO many stupid little adaptors lying around I found one for this easily… I reversed them and it works…so I got 2 wrong adaptors??? one from eBay which I got a refund for and one from Sweetwater who you would think would send the correct one but didn’t…?? bizarre…

1 Like

@pan34

That’s great!
Glad to hear you’re up and running now. :sunglasses:

FYI, Roland uses Type A TRS MIDI, according to https://minimidi.world/