Mapping MiniLab3 to MPC Beats

After wrestling with, and giving up trying to stop my new MiniLab3 crashing Ableton every time I plug it in (unplug it and Ableton is quite happy), I’ve decided to look elsewhere. Settled on Akai’s MPC Beats DAW - seems pretty good and easy to learn for a beginner (me). However, the MIDI mapping isn’t right, so I don’t have all the functionality from the MiniLab. I’ve found an old post where someone had done all the hard work mapping for the Mk 2 - haven’t tried that yet - but in the meantime figured I’d look for a solid map for the Mk3 that give transport control, knobs and sliders. :grinning:

Hey @sciencebadger sorry to hear you wasn’t able to use the amazing possibilities of our MiniLab3.

Did you tried to log in to your account and contacted our support team I’m sure they can help you to fix this situation easily based on your setup.

Best :zap:

I did - I got back a long list of how to videos. Unfortunately the one relating to Ableton was exactly what we did when setting up, so not much help. It’s a very weird problem and occurs when testing on another PC too, so something odd going on between MiniLab and Abelton. In the end I got too frustrated trying a myriad of settings changes suggested on other forums which did nothing, hence looking at other DAWs. Really like MPC, I just don’t have the necessary knowledge to know how to properly map the mk3 (which I assume I can as the mk2 maps). I might still pursue an Ableton solution, but my son (it’s his device) just wants to get on and use his MiniLab and make music!

1 Like

Weird thing indeed @sciencebadger :neutral_face:

I’ve been using the MiniLab3 on Mac with Ableton and it works perfectly also with AnalogLab Intro.

We wish you the best on your music projects!

Hello, I’m Aurélien from the Arturia QA team.
If you continue to have issue with Ableton, let me know and I’ll help you to troubleshoot your issue.

For the MPC mapping did you manage to do it ? It’s pretty easy to do with user programs in the MCC.
Let me know !