level knobs always reset

Whenever I pause the playback in Reaper, the level knobs within plugin reset themselves to their maximum values.

Hi @sqyq . Welcome to the community.

Sounds like some automation or modulation is going on.

Does it happens in a new clean DAW project with no automations and modulations added?

Does it happen in Pigments standalone version outside the DAW?

Does it happen with any preset?

If you against exspectation can say yes to all the above questions, then you can allways try to reinstall Pigments. Otherwise the answers to the questions should help us find out what’s going on.

Thank you for your response. I’ve discovered that once I add CC7 control, the level knobs tend to max out when paused. When I remove all CC7 events, this behavior doesn’t occur anymore. But none of my other virtual instrument plugins encounter this issue.While I can avoid using CC7, is it possible that this could be a bug?

I don’t understand why it max out, when you pause. A automation should just set the current value the automation have at the point on the timeline where the playhead is, when you pause. Are you saying it change to a value that’s not the current automation value?

And are you saying, that when you automate other plugins the same way, then the values change according to the changing automation values, but it does’nt jump to another value than the current automation value, when you pause?

Do you have somehow have something that send out parameter values to the volume, when you pause.

I don’t use Reaper. In my DAW i can’t reproduce the jumping behavior when pausing the DAW.

Yes, that’s what I mean. I don’t have any way of sending volume when paused, but I’m not sure what the DAW does when it’s paused. Maybe I should ask on the Reaper forum… I just realized someone else has encountered the same issue.

I’ve been unable to reproduce this in cubase 12 pro/win 10 either.
This does sound like Reaper is sending out some kind of midi reset message.

I made a quick search and found this: Volume jump on stop with master volume automation - Cockos Incorporated Forums
No speciel instrument mentioned here.
Also found this where volume issues is not about Pigments: How do I stop reaper from changing kontakt volumes? - Cockos Incorporated Forums

I have a hard time to believe this is about Pigments. I assume you have updated/ reinstalled Pigments in case it should matter.
Are you sure the other instruments you say does’nt have the issue also have long sound tails including effect tails?
Can each track have different automation settings?

Have you checked Reapers Preferences for anything that can cause this behavior?

To me it look like Reaper send out a midi CC message at playback stop.

Yes try and ask in Reaper forum too.