KSP Bricked During FW upgrade

I just tried to upgrade FW on KSP. Had logic open and got an error message. Something about a MIDI port conflict. Before I could even click on it the FW update failed (was only running for about 5 seconds) Keystep pro shut off and won’t turn on. Now MIDI control center won’t recognize it and it’s just completely off with now power nothing.

Hi @GregIcky

Sorry to hear this, have you tried a factory reset of your KSP?

You can find a guide on your to do this here.


Nothing works. It’s like there is no power going to it. I tried running the FW update again twice and it gets to like 12% and says it can’t locate the device or some such thing.

And yeah, holding oct + - does nothing.

Hi again @GregIcky

Ok, obviously that was worth a try, I think your next step would be to log in to your account to contact our support team that will help you to fix this situation.

Best :zap:

Please be aware that it’s holiday season in many parts of the world currently, so it might take a little longer than usual unfortunately.