Knobs 'jumping' in Pigments (not in Analog Lab)

When using Pigments together with either Minilab 3 MK3 or Keylab MK II, the knobs are ‘jumping’:
When I load a new instrument and turn any knob, it ‘jumps’ to the preset-setting of that knob.
I don’t understand why this would be the case, given that
a) there are endless knobs on both devices and
b) ‘picking up’ the knob-preset-value works fine in Analog Lab V.

I don’t think (I wouldn’t know how to be honest) that this is due to some configuration error on my side, I rather assume this is something Arturia could (and should!) work on.

Please educate me, if I’m wrong.

Given the task is already solved in principle with Analog Lab, I can’t think of a reason this would not work in all other software instruments.


Hi @StefanS ,

  1. Be sure the encoders is set to the Relative setting that work for you in the controller template you use.
  2. Be sure the parameters you wish to control by a Relative encoder in the applications is set to Relative mode in the Midi Config have selected. The MIDI Config is located in the right panel under the MIDI tab in Arturias applications.

This is in generel also how to make it work with none Arturia equiptment too.

In hosts/ DAWs there can be other ways to control things. But still it’s important to set the Relative settings, if things shall work relative where it’s possible.

Arturia Controller options for Encoders.
Arturia Controller Option for Encoders

Pigments MIDI config right click over a parameter menu.
Pigments MIDI config right clcik over a parameter menu

Hi @LBH ,

thank you for these tips!

I tried out what you suggested, it does solve the issue both for Pigments and for Augmented GRAND Piano. :slight_smile:

BUT: it does NOT work with the ‘relative’ setting in the Midi keyboard together with Analog Lab (there is no option to change the knobs from ‘absolute’ to ‘relative’) and the knobs don’t work any more at all. :frowning:

Changing the Midi configuration of my Keyboards each time I’m switching between Pigments or Analog Lab is no solution.

So, for the time being, I’ll stay with the ‘absolute’ setting, enjoy the experience with Analog Lab and keep my frustration with ‘jumping knobs’ in Pigments.

I’m still curios: if it works so flawlessly with the default (‘absolute’) settings of the Keyboard in Analog Lab, why does it not in the other virtual instruments?
Wouldn’t it be possible for Arturia to create a standard that is working by default for all their products?


It’s the same with Keylab 88 Essentials: in Analog Lab Pro (in Reaper) knobs are jumping all over the place (both with VST2 and VST3 plugins); also with VST3, moving some knobs using the “physical” knobs won’t do anything to the sound (although the knob is visually moving), I have to use the mouse to have some effects on the sound.
This has been going on for ages.

So sad to hear over and over again that Arturia doesn’t seem to take our (paying customers) experiences and complaints seriously.

What I can understand (with some good will) that they are not able to fix all problems for all DAWs out there. So I could accept jumping knobs within FL Studio - which would be sad enough and not the best statement for their customer- awareness anyway.

What I find hard to accept, that even their own products don’t work flawlessly with each other. Especially, when some do (Analog Lab) and some don’t (Pigments).
They know how to fix it (in principle), but they prefer leaving their customers frustrated. Too bad.

The default midi-setup for the MiniLab 3 in Pigments is just a pain in the ass. You have to create your own in order work with it in any meaningful way.

Jumping knobs even in working standalone with nothing but Arturia hardware and Pigments or Augmented Piano - I can’t believe they are saying ‘this is how thing are with Arturia. Live with it’ :person_shrugging:).

This is REALLY frustrating.

Hey @LBH,

how do you manage to work both with Pigments (or Augmented Piano) AND Analog Labs alternating?
As far as I understand from my testing, Analog Lab does NOT work with the ‘relative’ setting.

How do you deal with that?

Am I missing something?

Hi @StefanS ,

I don’t have a Arturia controller. I don’t know why it’s not possible to select it for the Analog Lab Mode template in one way or another, if that’s indeed is the case. I think there should be a choice somehow.
I would for example espect the controller settings to be in a template file. So i would probably try to find that and alter the knob mode in that, if it’s needed, and if it’s possible, which it very well can be. Also the Analog Lab mode midi Config file have to be changed.

It’s also possible to use a midi monitor to read the midi CC used in the Analog Lab template. A user template can be set to use the same midi CC numbers, and then change the knob modes.
And then choosing Generic MIDI controller like i use, then you get a configurable MIDI Config available.
(Copying the files and alter them is probably easiest if…)
I’m not sure if working this way will change display feedback or other functionality that work in Analog Lab mode.

I just use Generic controller mapping in all the applications, if i use it at all. I also have alternative methods with my controller and my DAW. But i also don’t have to consider speciel display feedback.

Using midi CC is in generel much about planning. When the hardware controls is set to the midi CC’s, then in Arturias applications it’s about creating and using MIDI Configs.

I think most people spend some time to find a way to work with controllers and midi CC that work for them.
Using midi CC’s is mostly not the same as having dedicated hands on hardware controls with names on for everything.

In example i think it’s easy to use the same midi CC numbers for the 4 Macro controls all Arturias applications have.
Beside this different instruments does’nt have the same parameters beside a few. So it’s about which parameter you select in the midi Config to be controlled by a certain midi CC. Another might select another parameter to control with that midi CC. It can’t be only one standard.

I’m not saying Arturia in some cases could’nt do better. There are topics in the forum about midi mapping.

Hosts can also require to be set to work in Relative mode to function. No controller can do things a host won’t allow.

There can be things that work different if at all in VST3 vs VST2. That’s also not about the controller.

I can understand frustration. But sometimes the fire may go the wrong way.

Where do Arturia say and do this?

Thank you again for your detailed answers, @LBH.

No, they are not saying this explicitly.
But - so many complaints for such a long time and no solution in sight, so I’m hearing ‘just live with it’.

And, given that I bought two controllers and several software instruments from Arturia, I’d expect them to work together without me having to dive so deep into midi CC codes and such tings.

I simply want to make music.

And I saw the Arturia-sign on your name-plate. So I thought you’d use Arturia controllers.

When you see that sign added to the user icon, then it just mean the person is a user that’s also a moderator but not an actual Arturia employee.
It’s not required you use Arturia hardware to be a moderator. I do own a Arturia Minifuse though. And i’m a long time V-Collection and FX-Collection user and owner.

Perhaps i will get a Arturia controller at some point.

I just opened a support ticket with Arturia, assuming this is some kind of bug.

Let’s see if they can find a solution or have an advice what I can do on my side!

This has annoyed me for a long time as well, so I’m just going to chime in here to bring more visibility to the thread.

A while ago I thought I found some settings in the MIDI Control Center that helped the situation a little, but it was still never as it should be (like in Analog Lab). From what I can see the settings I landed on were Option: Relative #1 and Acceleration: Medium. But when I try that now it doesn’t work at all. It might have worked with Pigments 3 but not 4.