Keystep 37 first step played when I start the sequence is wobbly

I have my keystep 37 connected to a korg minilogue xd via midi cable. When i press a key on the keystep, the sound is fine. When I program a sequence and hit play, the very first note has a weird wobbly/scratchy sound right at the beginning, then the rest of the sequence sounds fine. I thought it might be a remnant from the minilogue so I turned all effects off, but that didnt help. I’ve tried every possible midi setting on the minilogue and turned all of the keystep knobs all the way up and it doesnt go away. I cant really use it like this. Could it be latency?

The fact that it only happens when the sequence starts makes me wonder if it’s related to the MIDI clock signal. Sometimes, weird things happen when a synth patch relies on the tempo somehow and that suddenly changes, which can happen if the internal clock on the synth is at a different tempo than the MIDI clock. Do you have any tempo-synced LFOs in your Minilogue patch?

I’m just speculating, though. Is it possible to record the sound and upload it here?

I turned the LFO all the way down, and I tried it on several different patches with it turned up and down, including stock ones. I’m fairly new to this so I’m sure it’s something I’m not understanding, so I’ll take closer look at the MIDI clock settings. Thank you!

I took a video of it with the sound but I’m not sure how to post it here, I’m trying to figure out a way to do it.

Here is a video of it:

It’s hard to tell what’s happening. It sounds like there may be a tempo-synced delay effect that could be involved. Does it happen if you turn off effects?

Yes it happens when I turn off the effects on the minilogue. Ugh.

Sorry for missing that you already said that you tried it without effects in your original post. Does it happen when the KS37 is in Arp mode as well as sequence mode? If you have an unused sequencer pattern, you could also try testing a really simple one-note pattern to see if it happens there.

You are using MIDI, with the Keystep as the master for timing and the Korg as a slave in this instance. So the Keystep is “telling” the Korg when to play and at what tempo etc. I don’t know for sure but you may need to set the Korg to slave as it says in the manual:

"Slaving the minilogue xd clock to an external MIDI device (master)

Connect the MIDI IN connector of the minilogue xd to the MIDI OUT connector of your external MIDI device.

Set the “Clock Source” (p.41) of the minilogue xd to “Auto (MIDI),” and configure the external MIDI device to transmit MIDI clock data.

The minilogue xd will automatically act as the slave whenever a MIDI timing clock is received, and will be driven by the tempo of the external MIDI device (sequencers, rhythm machines, and so on)."

where p.41 states:

"Clock Source [Auto (USB), Auto (MIDI), Internal]

Many features of the minilogue xd can be synchronized to the tempo or BPM. This parameter specifies whether the clock source is internal, or an external MIDI clock source.

Auto (USB), Auto (MIDI): When there is no input, the internal clock will be used. When input is detected, the internal clock will be synchronized to external MIDI clocks from the USB B and MIDI IN connectors respectively.
Internal: Only the internal clock will be used…"

It may be worth checking these settings.

When the sequence loops, does the first note sound wrong every time, or is it only the first time after you press play?

Tried that and it made it make the weird sound on every note instead of just the first one. I appreciate your reply. I’ll RTFM a bit more :slight_smile: .

Just the very first note after I press play.

@Funtmaster @tmoore I’ve discovered that the sound is only really noticeable when I’m using certain presets on the multi-engine, which tells me the issue is probably with the minilogue. I think I can work around it. Thanks for your help!

1 Like

Try this : Don’t let the playhead start immediately at on your sequencer.
I don’t know what sequencer you use but you can let the play head start at minus a few millisecs. I have a lot of analogue gear that use midi sync (ex arpeggiator) and if I start the seauencer at dead it can also glitch on the first note.
So try starting at minus a few millisecs.