KeyLab MKII Encoder/Knobs not working properly

Has anyone else had issues with the encoders/knobs not sending constant data. All the sliders work fine but the knobs jump about all over the place, or don’t pick up when you turn them.

It has gradually got worse over time and now all 9 are virtually unusable. I’ve already contact the tech team and they’ve ruled out any software issue … appears to be the hardware which is such a shame as the rest of this controller is built really well.

I’ve had the keyboard nearly 2 years but I’m hoping the after sales team will get back in touch (still waiting, been a couple of week). All the knobs on my old keyboards (dating back to the mid 80s) still work fine so, I’d expect this one to be in full working order.

Sorry if you read this and you think “I’m not an idiot you know” , that isn’t my intention, just something that happened to me a couple of days ago.

I’ve only had my Keylab 61 mk2 for a few weeks and a couple of days ago I thought there was problems with both faders and especially knobs jumping around, but turned out it’s the way the preset designers had programmed the macros.

If I switch to user mode, all faders and knobs correctly go from 0 to 127

Ha … I am an idiot most of the time! Just not this time.

Yeah I’ve tried all of that. I’ve even checked the output via midi monitor … it definitely a hardware issue.

Hi @Danturia

Sorry to hear that Sales have not got back to you yet, it might be a better idea to log in to your account to contact our support team that will help you to fix this situation.

Best :zap:

Hi Mat,

Yeah I’m awaiting a response. Sales have put me back to Tech Support so I’m waiting for further info. Been going on quite a while now … but I guess they’re busy.

Was posting here just to see if others have had similar issues and maybe a solution. I’ve read similar issues so it might be a batch issue(?).

Hi @Danturia

That’s a fair point indeed, it’s a community/forum after all. :sunglasses:


That’s a known issue. In order to fix it, you can follow this complete guide : [SOLVED] Keylab 49 Essential encoder knob jumping values fix [SOLVED]

But I’ve found a simpler solution that don’t need any disassembly : just spray some “contact cleaner” (like WD40) at the base of the pimples (remove the plastic cap, and using a thin straw, spray all the way down each stem…).

I also spayed some light grease, because doing only the first works, but not for a very long time.

The 2 products I used:


Interesting! How long does it last? I don’t have the Essential model but the Keylab MK2 which in my case suffers from erratic knobs as well.

I did this only yesterday, I saw this trick on the linked topic.
I’ll keep people informed on this post.

1 Like

I did try using something similar using switch/contact cleaner and electrical lubricant - pulled off the knobs and applied a little down the encoder shaft. I used cotton wool buds to control how much went down. It worked great … but only for a few days and the issue gradually returned. The other thing to note (and this might not bother you) the encoders had far less resistance after they were treated.

In the end I replaced the whole PCB and that has fixed it as you’d imagine it would - but we’ll see if the issue comes back.

1 Like

Still working fine as of today :slight_smile:

1 Like

Cool! I was really expecting news from you, I will surely workaround it the way you did, thank you!

I saw somewhere I’m not alone - with my Keylab 61 Mkii, the first 4 encoder knobs no longer alter the sound. The virtual knobs in the software (Analog Lab) move smoothly as I turn the actual encoder knob, as do the values in the LCD display on the keylab. Also, with my mouse I can move/drag the knobs in Analog Lab, and this alters the sound. But with the encoder knobs, although the virtual knobs move, but no effect is achieved. Any ideas? (tech support is “down” at the moment). Clearly they are functioning fine, but there is a disconnect somewhere. Othe
r knobs/controls seem to be fine.

Update - This is only occuring with the VST3i version - When I use the VSTi version of AnalogLab, the encoders are working flawlessly. Think this could be something requiring a software fix?