Keylab Essential Mk3 not connecting

Hi yall,

I’ve had the essential mk3 for a couple of months now, and it worked when i first got it, but then I didn’t use it until yesterday and I can not get it to work. The device does not show up in device manager and reaper. It also isn’t recognized by Analog V and in the Midi control center it gives an error: Failed to open device, please verify the device is not in use by another application.

I’ve tried unplugging, restarting, using another cable and another usb port. The lights on the keyboard light up so it is at least getting power. I’ve also tried my old midi and that one was recognized in device manager.

Does anyone know any solutions?

Hey @Harmdepotvis welcome to our Sound Explorers community!

Ok a couple of things you could try spring to mind.
Have you tried using an old school ‘Din’ midi cable from your KLE MK3 to the midi in port on your interface, if it has one of course?
You could try uninstalling and then reinstalling midi control center and the driver for your KLE MK3.
Try those, if you haven’t already, and let us know the result.

If you haven’t already, please make sure to subscribe to our Newsletter to be the first to know about any new and exciting news from Arturia.

1 Like

Thanks for your response!
I solved the problem, apparently the midi came up as an unidentified device in my device manager, I clicked on it to update drivers and now it works :slight_smile:

1 Like


Thanks for updating us too :star_struck: