Keylab Essential 88 keys not workiing A#1 F#2 D3 A#4 etc

I have a keylab essential 88 that has been really good. hadn’t used it for about 2 months though during a holiday. After i got back though, im not getting any response from this key pattern A#1 F#2 D3 A#4 etc… plus all the record keys etc are playing notes instead of working etc…

So far I have tried

  1. Upgrading Firmware
  2. Cycling from DAW back to Analog
  3. Factory Reset (holding two octave shift keys, plugin cable, then pressing the center button)
  4. tried in Analog Lab IV and V and ableton.
  5. Check in Midi Control Center, those keys are not showing as responsive…

Any ideas?

Hi @Kapanther and welcome to The Sound Explorers Forum.

Sorry to hear this, is your unit still under warranty? If so you should contact the retailer you purchased it from, if not, you should log in to your account to contact our support team that will help you to fix this situation.

Best :zap:

can you download older firmware and downgrade? to see if that works?

@Kapanther Not as far as i’m aware.