How to sync an arpeggiator with a DAW Ableton (solve)

I bought a minilab 3 and found that the arpeggiator does not sync with the tempo of the DAW. There have already been posts about this on the forum and on the Internet too. I accidentally found a way to make it work.

  1. Set the arpeggiator to the auto sync mode “Auto” and do not change this setting again

  2. In the Ableton midi settings, set the sync checkbox to “minilab 3 midi out” item

  3. switch minilab to DAW mode (shift + third pad)

  4. Then, while holding the shift, press and hold the Tap pad for a few seconds, after releasing the shift button, hit the Tap pad few times — the tempo in the DAW will change.

  5. Now the minilab 3 arpeggiator is synchronized with the tempo in the DAW. If everything is done correctly, the tempo of the arpeggiator will change along with the tempo change in the DAW, even in the “Arturia” plug-in mode.

I hope this will be fixed in the next firmware versions. The arpeggiator in Ext sync mode does not make any sounds if it is selected

Thanks for sharing this guide!

I’m not sure what you mean should be fixed in the next firmware version. As far as I know, this is working as it’s meant to be.

In Ext sync mode, it relies totally on MIDI clock sent from the DAW. Ableton only sends MIDI clock when the transport is running. The arpeggiator runs when Live is playing (or recording) and stops when it is stopped.

When you use tap tempo in DAW integration mode, that also has the effect of starting the Ableton Live transport if you have “Start Playback with Tap Tempo” enabled in its preferences.

The Auto mode was added in MiniLab 3 firmware update 1.1 so that it will use its internal clock when it doesn’t receive MIDI clock. It will sync the internal clock to the MIDI clock when it’s received, so by starting the Live transport first, it will cause the MiniLab internal clock to be set to the same tempo. If you then stop the Live transport, the internal clock will continue to play at the same tempo, and the Auto sync mode will fall back to using that.

Unfortunately, the MiniLab 3 manual hasn’t been updated to reflect the changes in firmware 1.1 yet, so you have to rely on the video to see how that works:

I had a Novation Lauchkey mini mk3 keyboard, and I also have Impulse 49, which also have an arpeggiator, and they immediately synchronize with the tempo of the DAW during the creation of the project. That is, you don’t need to start recording or playing something to start syncing. How do I do this with minilab 3?

That’s interesting. I don’t have those other keyboards and I don’t know how they work. They must be receiving the tempo from Ableton somehow. The only thing I can think of is that the custom Ableton Control Surface script is able to query the project tempo and set it on the device. I’d contact Arturia to see if that could be improved.