Horrible Experience Setting up the KeyLab Essential 61 MK3 with Cubase. Everything ok at Arturia?

I am trying to setup Cubase with my KeyLab Essential 61 MK3, but I am not having much luck as posted elsewhere. I see there is a specific guide for each DAW as noted here on page 43 of the KeyLab Essential 61 MK3 Manual, but when you click that link, the page and I see now specific DAW guides at all. Where is the guide?

Ok…after reading through other forums I realized the Cubase manual is on the above page, but you first have to click “Show Archives” to expand the “Scripts” section to find the “Script” for Cubase which surprise surprise, comes with the Guide in the download. This is really poor design as

  1. show archives feels like you are going to browse older scripts not all scripts
  2. I was told to look for the Cubase Guide on this page which is hidden in a script download WTF???

After I downloaded the script, I read the guide and completed all the steps and while the transport controls do work when I select DAW from the Prog button and press play or stop for example, I also hear a note played at the same time? Here are my settings that the script automatically sets up.

Since I am new user…I have to share the screenshots over 3 replies (enshitification to the max here). Here is the first one.

Here are my Arturia MIDI Control Center settings below too:

Finally the video on Cubase control from Arturia does not go over the setup at all, just how to use it when setup. Everything ok over there Arturia as you almost had a perfect intro, but now I am left wondering if I invested in the right company.

Oh and the script provided shows a missing Transport button and not all the buttons have the same icon.

One more thing too…the knobs and faders are backwards on the above keyboard screen in Cubase that the Arturia script setup. Turning a knob makes the fader below move and moving the fader makes the knob above it move.

Emailed support stating Cubase 12 as 13 is not on the form yet and I got this reply…of course.

“We wanted to inform you that we are currently experiencing an exceptionally high volume of requests, which has resulted in a temporary surge in our workload. While we are diligently working to address each inquiry with the utmost care and attention, we anticipate that our response time may be longer than usual.”

Is Arturia losing money staff or another major issue as they seemed like they are a great company, but this experience is horrible.

You are using the wrong script!
The one from Steinberg is not for the mk3 version!
Please try to disable the script from Steinberg and delete all entries in your “MIDI controller” dialog in Cubase. Then add the mk3 again and make shure to use the MIDI-port. Also check your device settings in Arturias MCC

See my answer to your other post

Update: Been in tou ch with Arturia support who have been great. We have tried many steps to rectify but nothing seems to fix the transport controls not working in Cubase. I even sent them a video of the entire setu p process and they confirmed it was correct. They are just as confused as I am. I have no other MIDI devices or software. That said, I did try the demo of FL S tudio and everything worked out of the box. This m eans the keyboard is just fine (I was wondering if it was faulty), but Cubase 13 for me at least is not. I am switching to FL Studio as I actually like it better than Cubase, but I have committed to continue to work with Arturia to solve th3 Cubase issue as perhaps others will encounter.

Same issue here with CUBASE13. Finally got Transport to work having deleted the other Steinberg Script for this KL61 which it is not for the MK3 (so now just 1 Script Active).
Then I had to Right-Click on the PLAY and select the right pane window to see PLAY and select the PLAY in the binds on the left to match. From here it started to work…
However, it only works for this Song File and lost the setting after a PC Shutdown.
I had previously added this Script to connect via HUI which it does show as such in the MIDI APP also which I believe is the key.
Sad it is NOT PLUG & PLAY and is falsely advertised with CUBASE for this purpose!!!