Hold button getting set by DAW

I use Studio One (Mac) as my DAW and am finding that for both the PolyBrute and MiniFreak the Hold button will sometimes turn on. This obviously then causes the notes played by the DAW to hold too.
It’s not at a consistent part in my track and seems to be random. It’s also not on both devices at the same time.
I have PolyBrute Connect and MiniFreak V to control these devices and wonder if these have something to do with it.
Currently I can’t figure out what’s causing it and wonder if anyone else has experienced this.

Hi @MarkPoston . Welcome to the community.

It sounds like you somehow send automation messages from your DAW. You can for example check if you have the issue when not using your DAW.
Or perhaps a messages from your Sustain pedal is send. You can check by disconnecting the pedal.

I don’t have the instruments you mention.

Possibly MTC start/stop messages?

@matjones @LBH thanks for your suggestions. I will take at a look at these options.

I hadn’t been using a pedal although have them connected to other devices in my setup. I’ll disconnect and see what happens.

The MTC start/stop is also likely as at a couple of point it seemed to be due to start/stop in DAW. But had noticed it too when simply playing the track.


I often ‘catch myself out’ with this if i want to use one of Cubases arpeggiator plugins instead of an onboard hardware arpeggiator and vice versa.
Being a Cubase user i don’t know where you’d find those settings in Studio One. They’re in the ‘Transport’ options in Cubase if anyone else is interested.

@LBH it seems your suggestion of the sustain pedal is the reason. Moreover the MIDI controller message sent to the PolyBrute from one of my tracks. I must have been stopping the track before a sustain off message was sent, and therefore is was remaining on on the device.

This was the same for the MiniFreak.

So thanks for the advice.

Thanks for reporting back Mark. Glad it’s solved.