Help! My unit is bricked!

Support mailed me a custom procedure to update the firmware, and I followed this to the letter. It didn’t work, so I re-installed the version 2.0 firmware through the official procedure, taking note of the firmware update instructions on the website.

Right now, my unit is in a bricked state, where it does no longer listen to the “shift + oct(-)” command, thus it cannot be taken into boot-loader mode.

All it shows is the Minifreak-logo with an animated particle background! There is also no USB-connection sound when I use the cable.

Does anyone have experience getting out if this state?

Have you tried rebooting your computer? It might have disabled the port.
This is what I would try:

  • Shut down both computer and miniFreak
  • Make sure, miniFreak is plugged into its power supply. Unplug USB.
  • Reboot computer.
  • Load miniFreak V.
  • Start miniFreak with Shift and Octave depressed.
  • Plug directly into a USB port on your computer.

Hopefully miniFreak V will show the update prompt.

If the update has trouble, do not turn off the mini Freak, but restart the computer.

I had the same issue with my first two Minifreaks, when firmware V1.1 was released. The first one I exchanged for a new one at my vendor. The second one I had to RMA to Arturia to get fixed. If your Minifreak is indeed stuck in this bootloop, the only people that can help it get out of it is Arturia support.

If you are still connected to the PC, you can try the tricks posted by HaraldS, but if those don’t work for you, the only option is an RMA to Arturia.

Thanks for the suggestion, HarandS. Sadly I didn’t get that to work, as the MiniFreak still did not want to make a connection.

Support has been unresponsive for 10 days now, so I’ve decided to return my unit through the vendor. I had hoped Arturia would offer me a direct repair route, as my vendor charges extra for their assurance package (which was the only way to get a replacement within a reasonable time-frame).

I’m disappointed with the timeliness and quality of the support I have received from Arturia.

You could try starting the device in boot loader mode;

-Turn off the mini freak.
-Press and hold the shift and octave down buttons.
-Whilst holding those buttons, power on the device.
-Plug the minifreak into your pc
-Start up minifreakV (the standalone, not from within a DAW)
-on the settings bar (on the right), under where it lists the minifreak, select update. (I recommend downloading the firmware from the Arturia website rather than doing it through the standalone software)
-wait for the update.

Hopefully that’ll work for you.
I managed to brick my Astrolab within an hour of receiving it and had to go through a very similar ordeal!

Thanks for the reply, but as mentioned, the device does no longer listen to the shift+octave down buttons and does not get into boot-loader mode.

Ah, sorry I missed that. I will note though, and sorry if this comes off as condescendingly simple advice, that, at least on the Astrolab, merely holding down the buttons during powering on didn’t actually put it into service mode… Rather, by quickly releasing and then pressing the relevant buttons again after the device powers on, the mode was activated.

If you haven’t yet tried this, I would suggest giving it a try.