Help... dead keys, wonky faders, unit freaking out

I’m having all sorts of issues with my 1 year old Keylab61 mkii.

The two worst things right now…

  1. Dead keys. I have dead spots in the keyboard every eight half-steps. So all of the D, B flat, and A flat keys are dead.
  2. In DAW mode, if I touch the knob on channel 7, the unit FREAKS OUT and starts flashing wildly, and dumping commands to the DAW, and causing the DAW to make al sorts of horrible noises.

That’s just for starters. In DAW mode, the channel 3 fader, button, and pan knob do not work. The channel 5 fader starts the transport play function when placed at the bottom.

My current system is old I will grant you, and I really don’t want to buy a new Mac but it’s Apple so I’ll have to eventually. They didn’t become the richest company on Earth by making products that you didn’t have to constantly replace.

I’ve sent an email to Arturia tech support but it’s been three days and no answer.

Anybody have any ideas? Thanks!

My system -
Logic Pro X 10.5.1
MacOS Catalina 10.15.7
IMac 2013

1 Like

Not sure if it’s the same problem, but I have similar issues from time to time when I power mine over USB. The issues disappear when I plug in a power cable.

@karnubawax Sorry to hear you’re having these issues, have you tried contacting Arturia Support directly? You can do so here

@StijnNotStain Have you tried a different USB cable and using a different USB socket on your computer?
Also worth checking, very carefully, if there is any dirt or lint in your USB cable and ports.

Yes, I tried different cables and checked the sockets. I’m pretty sure it’s due to the limited current my USB power source (Roland Fantom) is able to provide.

Have you tried a different USB port on a different device or an external PSU?
Sounds like you may have answered your own question.

I’m sure you’ve done this, but is the controller plugged directly into the computer and not through a hub? I had problems in that regard, even with a powered hub.

FWIW, get the best quality USB-B cable you can afford. It really does make a difference!

The power supply cable is always a good idea anyway, USB power isn’t the most reliable.

I had a similar problem:

  • some keys not working
  • scratchy noises from the master fader
    Two years ago this had happened too. I then somehow resolved the problem,
    but today could not remember how.
    As this occured only in Ableton Live and not while using the standalones
    (Mini V3, Stage-73, … ) I guessed:
    “Maybe it has to do with my switch from Ableton Standard to Ableton Suite.”
    I compared the settings of the old and new Ableton installation, and “Voila!”

    These settings work for me.
    Don’t know, why Arturia or Ableton put the Keylab MkII twice in the devices
    or why there is a Port 2?
    But it is important to choose Keylab MkII 61 (Port 2) in the Input and Output!
1 Like

I have exactly the same issue, except my dead keys start on the lowest Eb and go up every 8 half steps from there (Eb-B-G); died about 14 months after I purchased it (Aug 2023, bought Jun 2022). The rest of the unit functions fine, but is essentially unusable if I can’t use they keys.

Plugged in directly, changed USB cables, plugged into different computers, different ports, no hubs, went through a bunch midi diagnostic hoops the Arturia techs had me do only to conclude it’s basically a hardware issue. Dead keys regardless of me using Logic or the Arturia keylab standalone software, tested on 2 different computers.

No criticism on the part of the tech support, they did their best to help and I was appreciative of that help.

Disappointment though goes w/out saying $700 in the dump for a now oversized paper-weight after just over a year of use. Wasn’t expecting that. I have a Roland A-33 midi controller from a thousand years ago that’s rock solid and if that died I could understand, I’ve owned it for over 20 years. But the keylab?? Come on.

And now unfortunately there’s really no recourse w/ the expired warranty. I’m toying with the idea of getting it repaired, but that’s a big but…

Logic Pro
Mac Mini M1
OS X Monterrey I think
Arturia software synths (which I love). Should have just stuck to the software, it’s fantastic.

Not sure if your issue’s been resolved, but if you have found a repair, I’d love to hear about it.

HI @KostasC and welcome to our Sound Explorers Forum.

Really sorry to hear about your situation, that’s not good!
I don’t know which country you are from but, here in The UK, we have legislation which can actually supersede any statutory rights in regards to situations such as this.
If a device stops working after its arbitrary guarantee period it’s possible to argue that it should work for a ‘reasonable amount of time’. Personally if i was in this position i would be contacting both the retailer i purchased the unit from as well as The Trading Standards Department to make them aware of the situation.
Not being sure which country you are in, it might have been a good idea to see if there is any local legislation like that in your area.

Sorry we couldn’t be of much more help in this case.

Hi everyone! I haven’t checked this thread in a while, and I noticed there were a lot of questions on here. Unfortunately, I’m out the door going to work, but I will post an update on here tonight!

Long story short… after a lengthy (but friendly) back and forth with Arturia support - trying all sorts of software fixes - Arturia concluded that the unit was indeed broken and fixed it. That’s the short version. I’ll tell you the whole story tonight!

Don’t give up hope!!!


Hi @karnubawax

That’s wonderful news!

Looking forward to hearing about it. :sunglasses:

OKay… so I promised an update.

So I got in touch with Arturia support and we tried all kinds of software fixes, trying different things, doing a hard reset on the keyboard (which, by the way, it would not do. When I held down the two reset buttons and turned the unit on, nothing happened. No prompt), and so on.

Eventually we tried running the keyboard independent of any software, then treid it just using Analog Lab, and nothing worked. Arturia said send it in.

So yeah… Arturia paid the postage both ways and fixed it at no charge. But here’s the thing… I purchased the unit a year and a half ago! That’s right - it WASN’T under warranty and they STILL fixed it. I mean, I assume that the warranty was one year, right?

So yes, it took a few weeks of back and forth to get to the point where they took it back, but ultimately they did fix it and the unit works fine.

So don’t give up hope! Reach out to Arturia support and ask them what they can do. They might surprise you… they surprised me!

Now, I never found out exactly what was wrong with it to begin with, but if worst comes to worst and you have to try and fix it yourself, I might start by looking at the data cables. Logically, that would seem to be where the problem might lie with the dead keys. Maybe disconnecting them and giving the contacts a good clean could fix the problem.

If you have any questions let me know.

Good Luck!



Many thanks for the update, that’s REALLY great to hear!

By the way, if anyone is interested, the company that Arturia outsourced the repair to is called TAP electronics located in Buena Park, CA. They do have a website, and - although Arturia is not on their list of authorized repair partners - they might be able to help you out if you need out-of-warranty repairs.