GUI Error after purchased sound bank


After making a sound bank purchase and installing I am left with this error message attached with picture. I am unable to load further and have to exit the plugin. Only soulution is to reinstall the plugin thankfully, but I am still out money with a sound bank I cannot use. Anyone know a solution to this problem?


Are you installing the sound pack through Pigments? If so, try to download the individual installer from Arturia’s website and see if it installs correctly that way.

If that still doesn’t work, I wonder if it could be a file/folder permissions issue on your system?


I downloaded the installer from my products page on the Arturia website. Odd thing is in the desktop app the only product I have listed is my Pigments, but on the website the Expressions sound bank is there and registered.
I agree there seems to be a disconnect somehwere with authentification or something. Really frustrating.

It’s normal that the sound banks don’t show up in the Arturia Software Center application. That only shows full software products, not add-ons.

It might also be a good idea to try un-installing and re-installing the ASC application as well, then try re-installing Pigments and the sound bank. If it still gives the same error after all that, I’d contact Arturia support. Something may either be getting messed up in the install process or you have some weird file permissions issue on your Windows system.

Thank you for taking the time to respond. I will open a ticket with Arturia support as well. Hopefully I can find a solution to this.