Firmware update

Since Microfreak got this new great update 5.0 allowing samples, when will it be possible for Minifreak ?


Hey @Lovelight we’re glad to have you here :zap:

The MiniFreak is quite new and it has the amazing possibility to be updated as we will be launching new features.
To be sure you don’t miss anything you can subscribe to our newsletter to be the first to get the fresh news :control_knobs:


Hey guys.

I see u all excited here, sharing new firmware updates… I really want to make an upgrade and play around, too, but I am unable to. I keep getting some kind of error and it says my device is not connected to the MCC. (Trying on different Mac computers, both with and without a USB port, original adaptor is plugged in.)

  1. I currently use a Mac Air 2020 (Ventura), of course I had to use a USB port since I do not have the right cable to run it through without it. I failed, I get it.
  2. I tried it on my old MacBook Pro (2011, good ol’ pal) and I plugged it in directly to the computer, I still get the exact same error, It says “failed to init device manager”.

I tried with different cables, tried switching everything on and off, tried to close and open back MCC again and again, yet still It does not work.

Can somebody help me here, please? What could I be missing?

Thank you in advance.

Anyone had luck updating firmware on the MiniFreak? I’ve owned mine since last November and am still running 1.0 but don’t want to update for fear of bricking my board.

Of course someone had luck to upgrade the firmware. Mine has been upgraded with MacBook Pro 2018 with MacOs Ventura latest.
First: Connect You MiniFreak to power source (the one that came with it).
Second: Before launching any software - connect the USB cable to computer and make sure the Freak is visible to Computer. No USB hubs are allowed! Quit all the programs (command+alt+esc and force quit everything exept finder). Mac users have tendency to not quit the apps but close the window with red X button.
Third: Get Yourself good nice cappuchino and lot of patience. Then launch the firmware upgrade and follow the instructions. When it seemingly gets stuck at some point of time - let it finish (it took looong before I realisedm that it’s still doing something).
Be sure, that Freak restarts itsself in the end.

1 Like