Firmware 2.5 Program Change

Anyone else having trouble getting program change to work? Going out to SE-02, monologue, Microfreak and MS2000r. Getting nothing. I reached out to support last night and they got back to me pretty quick suggesting a factory reset, which did not do the trick. Still working with them. Haven’t had any issues with previous updates. Just seems odd.

Finally figure out what I was doing wrong. Working now. Feel free to hit me up if anyone runs into it not working for them!

1 Like

Hey @barcsdad

Great to see you’ve made it here to the new Sound Explorers Forum.!

It would be great if you did post your ‘fix’ for everyone anyway, it would make it available for the entire community and save you and any potential user wanting the info having to ‘back and forth’. :sunglasses:

1 Like

So turns out the “solution” isn’t exactly a solution. After further testing with this, it seems that when creating program changes on patterns that I’ve never used before (say, project 16, where I’d never created anything), that is when I was able to get it to work (as per the instructions in the video/manual). However, once I went back and tried it on my existing patterns, no go. Which makes sense, as originally when I first was trying out the functionality, I was using existing patterns. I definitely can’t explain why this would be. But I can replicate it. If this is going to be the case, that’s really awful. I’ve maintained a spreadsheet containing patterns and synth patches, and was hoping I’d be able to finally program them all. It’d be great if someone else could verify what I’m seeing with this. I’ll keep trying to get it to work on my old patterns in the meantime.

1 Like

You mean , existing pattern cant handle programmchange?

Seems to be the case. I can replicate it quite easily. I want to try erasing/deleting an existing pattern and create a new one with a program change, as well as trying to copy an existing one to a new location then adding a program change. Those actions could possibly work.

Arturia has acknowledged this issue (they were able to reproduce it in the project files I supplied) and I assume are working on a fix/update. But you know how those things can go.


I’ve struggled with the patch change implementation too - does not seem possible to have just MIDI program changes without bank select.

I can’t seem to get my head around the process for saving in any of my existing patterns either - seems rather convoluted? I also have what seems to be a bug requiring power off/on…
If I follow manual, when I get to part where I press Pattern, the display goes blank and the pattern button turns off. I then have to power off to get display back again. Indeed, whenever I’m in the prog change assign menu and hit Pattern, that track’s display turns off and requires a power cycle to turn on again.

I don’t see why I can’t just select the patch I want for the current pattern, save the pattern and that’s the end of it. Wouldn’t that make sense?

1 Like

I’ve done a bit more messing around with this after Arturia got back with me, and did hit on what it sounds like is happening with you. It seems pretty specific though. I can set up program changes successfully on all “sequence” tracks (that is, on a “virgin” project/pattern). I have a drum machine that I have in the mix, but I program that and just have it synced so when I start/stop the KSP, it starts/stops as well. When I try setting a program change on the “drum” track (set to a different MIDI channel than the synth I have set up on Track 1), I get that same result… the lockup that you are getting. That is the only time I’ve encountered that, and was wondering if that is the case for you as well? So basically, the lockup for me only happens when attempting to set a program change on the “drum” track when there is also one set up on the “sequence” for Track 1.

1 Like

I’m not using the drum track (indeed would love to replace it with another Arp) .
In this, my first project, I have a Waldorf Blofeld on track 3. I’ve made half a dozen patterns that I’m happy with and wanted to associate certain patch changes with some of them. Each time I set out to do it, I run into problems, either of just not understanding what I’m supposed to do and see or just the program changes being apparently stored then not there later. It’s kinda frustrating as it seems like the only way I can associate patches and patterns is by writing them down and setting manually, but surely someone is making this work?
I have a brand new Chroma and have used patch changes (with and without bank select) on everything from Atari Cubase right up to Cirklon, never with any difficulties.

OK, I think I’ve sussed it. The process is a bit clunky though…

In my case I’m working with the Blofeld and don’t want to leave bank H cos that’s where all my patches are. The first issue is that, although I can set up program changes to happen on specific patterns, the display doesn’t always show which patterns have program changes in them. I just watched it go from pattern 8 being lit (to indicate a program change) to it not being lit as the play indicator passed it. I reselected it and could then see a program change and it stayedlit again for a while.

OK, kinda hard to trust it but that’s not the main issue… if I want to set a new program change for a different pattern, as soon as I start to change the PC Assign value on the KSP, it puts the Blofeld in Bank A, cos that’s where it thinks you’re always going to start from (!) You can’t turn it off either, as far as I can tell.

So each time you want to pick a new program change, you have to first go to the bank select screen (MSB in the case of the Blofeld) and set the value for the bank you want, then go back to the program assign menu. Until Arturia allow you to turn bank select off, I think this is gonna be the case…

Believing I’d saved all the patterns with program changes in them, I powered off and on, only to note that several that were working fine have now gone. It makes me wonder if you have to set them all in one pass or if a subsequent patch saving opertation will lose the older ones… Oh well. I think I’ll leave it for now.

I’d encourage you to put in a support ticket with Arturia with your specific issues. They have been responsive, and hopefully it will lead to a bugfix update. I let them know about the lockup issue I’m seeing with the drum track (which may be related to what you are experiencing), and they asked me to send them another video showing them how I can reproduce it.

1 Like

I will, thanks. I’d raised a ‘help’ already about turning off bank select and hoped to provide more info once they replied. Fingers crossed they will. Right now I want to have a few days simply enjoying my new purchase - seems like it’s been one long battle to understand what’s going on so far.
Weird how this topic keeps telling me not to reply as this topic has been solved - is that normal for this forum?