[Feature Request] Keylab 88 mk ii Max Velocity Calibration

Long shot, but I just bought a Keylab 88 mk ii and I’m noticing that when playing at mf/f levels, I’ll already be triggering max velocity. Many of my instruments reserve notes at 127 velocity for the hardest possible strikes of a key, and it can feel a bit awkward having to scale back my touch so much just to avoid triggering those samples.

The custom velocity curves aren’t much help as they’re already set to trigger maximum velocity at 127, so I’m assuming it’s a keybed sensor calibration issue (or design)

I highly doubt it, but is anyone aware of a way to change the keybed calibration so that 127 velocity isn’t triggered until striking much harder? It’d be a real shame to have to sell this controller on due to velocity sensitivity issues. It looks stunning, it seems to be built very solidly and has some great features. But I can’t understand why it would be designed to max out so quickly. I might pop back to the store to clarify if it’s an issue with my unit, or they’re designed that way.

1 Like

I have the same exact issue with my Keylab 41. I had a long constructive conversation with custumer service about it, sent the device in - and got it back just resetted to the factory defaults.

If you’re able to get rid of that problem I’d be outmost interested in an solution :slight_smile:

Although I literally love evey other aspect of the Keylab, it’s pretty useless for me in this state. I just hope for the mk3 to have fixed that issue.

1 Like

We have the same issue with my son’s new Keylab 88 Mk II. The best we could do was upgrade the firmware to the latest 1.3.1, factory reset the device, then set the global key velicity map to “log.” This is the closest feel to other keyboards we have including the Roland RD300s, Korg D1 and a Kurzweil K2700. But the Keylab 88 Mk II still max’s out too quickly.

Quite dissapointed with Arturia on this.

Also, we cannot seem to get the Arturia ‘MIDI Control Center’ to change the keylab velocity settings, even though the app is connected and sync’d. Maybe it’s a user issue. So, we changed the settings on the device itself. (Hold down “USER” for over 1 sec, press the “global” marked keyboard key, then navigate to keybed velocity map using the scroll wheel. For some reason this says it’s saving to USER 1 but it sticks globally.) The user interface on the keyboard, MIDI Control Center and the documentation could do with some improvement. I’ve had many difficult to program keyboards over the years, including Kurzweil, and the Arturia is a mess.

Hello @msmithers @CTravaglini @loph

Sorry to read about the troubles faced. I hope this information will help you all :arrow_down:

  • So, in order to adjust the keys “Velocity curve” with the help of the “Midi Control Center” → “Device Settings” → “Global Velocity Curve” option, make sure to do the following:

-Hold the “User” button on the controller until it blinks

-Press the black key below the “Velo Curve” mention above the keys:

​​​

​​​

  • Move the jogwheel to select “Velo Curve:Glo” (which means that it will follow from now on the “Global setting”) and press the wheel to validate

  • Press the “User” button and click on the wheel once again to save the changes (You can then select any Device Memory with the wheel and validate once again the selection with a click on it).

  • Once done, open the “Midi Control Center” → “Device Settings” panel and then adjust the “Global Velocity Curve” as desired:

  • As a side note, the “Custom” curve will follow the settings defined in the “Custom Velocity Curve” section as showed below:

Hi Arturia,

Thanks for your reply. Unfortunately you’ve missed the point of the original post above.

The velocity curve just affects how the key velocity maps between min and max - MIDI 0 and 127.

The fundamental issue is that with the Keylab 88 MK II, the physically velocity needed to achieve maximum key speed (127) is lower than on other keyboards from other brands. So a player who is playing at a moderate level will trigger maximum note level on the Arturia. The velocity curve setting doesn’t help with this. There needs to be a re-calibration of key speed to velocity numbers!!! How can this be done??

Here’s a diagram that shows how the keybed calibration needs to change

Michael

2 Likes

Nice work Michael!

I’d like to add my point of view to that issue.

I do like that playing softly triggers really low MIDI-Values, but just like Michael, I feel that 127 values are triggered far too soon. So, the current “dynamic range” of triggered Midi-values appears to be too narrow. I’d like to have more dynamic control over my key strokes (the green line in my picture).

What I can do with the velocity curves of the Artura software is approximate the velocity of the key strokes to a certain level (red line in the picture), but this way, I lose the dynamic top-end.

In addition, the velocity curve seems to be glitchy on my device, so there’re still really “loud” key strokes poured in from time to time.

Unfortunately, this way it’s very hard to play “properly” on the device. But if this problem could be solved (at least in mk3), the KeyLab would be the best controller on earth.

2 Likes

Thanks so much for sharing your analysis of the key velocity! @loph @msmithers
and I’m sorry my reply went the other way.

If there is any possibility from our side I’m pretty sure our support team could help you figuring out.
Please feel free to log in to your account to contact them, they will be happy to help you to find a solution.

:zap:

Hi nats,

We’d appreciate more help than just ‘contact our support team.’ I have a support ticket open on this and it’s clear the teir 1 support folks don’t quite understand the problem, as described here. (I have forwarded the support folks to this thread.)

Michael

1 Like

I’m so thrilled there are others who share my experience with this velocity issue! I have opened up a ticket with Arturia customer support, and if anything useful comes of it I’ll report back here.

In the interim, I did manage to “brute force” a workaround that helps increase the dynamic headroom. This modification could void your warranty, so perform it at your own risk.

Keyboard velocity is detected by 2 sensors that sit underneath rubber inserts. When you depress a key, sensor 1 makes contact before sensor 2. The timing difference between the two sensors determines the MIDI velocity value. The faster the key is depressed, the closer in time the 2 sensors are triggered and the higher MIDI value will output. You can make a physical modification to the detection PCB to raise one side of it, which will force sensor 1 to be triggered earlier than sensor 2. Therefore there is a larger time interval for any key stroke, which we have achieved by physically moving sensor 1 further away from sensor 2.

To perform this modification, you’ll need to remove all screws from the keyboard (including the music stand/laptop stand screws) and then very carefully lift the assembly with the screen/faders up from the base (be careful as there are 2 very fine ribbon connectors which are easy to pull out by mistake) Ideally, have a helper to guide the keyboard shell up and away from the base, and have something to lean this shell up against. Then you’ll have to remove all the keys. I’m unsure how this works on the synth action boards, but on the 88, it’s as easy as pulling the key away from the assembly. Prepare to get white lithium grease everywhere.

Once all the keys are removed, you’ll see the PCB with the rubber sensors. There’s 2 rows of screws. I removed all the screws along the whole board, and then underneath the top row of screws (the row closest to the back of the keyboard) I placed a small nylon washer, approx 1mm in depth. I did this for every screw on that side of the PCB. Once completed, put the board back together and get plugged into your favourite virtual instrument (ideally a piano or rhodes type sound that you’re familiar with)

Personally, after this mod, I had to set up a custom velocity curve in the arturia midi control centre. I had much more headroom, but I now had the opposite issue where the board wasn’t sensitive enough. Luckily, that issue was much easier to fix with the custom velocity curves. I experimented with the mezzo/forte velocities until the board felt comfortable, and then saved that to the board.

It’s by no means a perfect solution, there are still a few random glitches where 127 notes pop out randomly. But it’s a whole lot more useful than before. Let me know if you’d like any more info/photos or videos of the modification.

3 Likes

Hi @msmithers, yeah, that’s the idea of this forum to share community knowledge :metal:

I’m impressed by the great feedback @CTravaglini just gave.

Thanks so much for all your inputs!

Several contemporary reviews of the Mk1 KL88 noted that the keys took a lot of force to get a 127. This was backed by a number of complaints on the legacy forum from users complaining they all but had to whack the board with a mallet to get a 127. So it’s very likely Arturia took these criticisms on board when designing the MkII KL88. But now they’ve irked the wrath of heavy-handed players who can’t stop triggering 127’s. I feel compassion for Arturia with this because it’s a loose-loose scenario.

1 Like

Hi @Jon_Vincent I agree this behavior on the KL88 should be fixed and we are working hard to get better results for the new products.

I wish the limitations from actual keyboards velocity calibration could find a solution soon, please be patiente and be sure if there is a better solution our support team is willing to help you.

Hi all,

It would be very good if a controller both had different curves and different sensitivity levels to reach max velocity and max aftertouch for that matter.

2 Likes

I feel compassion for Arturia with this because it’s a loose-loose scenario.

Sorry, I don’t think this excuses Arturia. I don’t think they;ve done their homework when setting the calibration. I have 88 note keybeds from Korg, Roland and Kurzweil right here, and all are more playable than the 88mk2.

@CTravaglini great work. Maybe 2 layers of painters tape, rather than a 1mm washer, might be the go? :slight_smile: I just repaired a similar keybed here in a RD300s - from the late 1980’s - but from your description it sounds like the Arturia keybed is harder to dismantle. Some photos would be great, thanks.

@sand.arturia , Arturia support won’t acknowledge the problem. Here’s a quote from “Gabriela”:

“… at the moment this is indeed more related to the way you would like it [the Keylab 88 MKII] to respond and therefore I will log it as a feature request and I will forward a proper report to the dev team (including the comments of other customers in the forum) so they take this into account for future firmware and developments.”

@sand.arturia The keylab 88mk2 is a really great keyboard and nearly perfect - with this Request it would be close to 100%. Is there any hope to get a solution for this, before the mk3 is coming and the mk2 is out of development?

I only want to get you to remember this in the new year…
:slight_smile: