Delay pressing keys and hearing the sounds


I’ve just got a Keystep Pro. At the moment I’m just trying to use some of my Arturia software instruments standalone and I’m getting a delay between pressing a key and hearing the sound.

I’m using a windows 11 laptop, connected via a straight USB cable. Is this an easy fix?

Any advice appreciated. Thanks!

This is known as “latency” …the time between the action (pressing a key) and the response (hearing the sound).

For this kind of basic scenario, just the Keystep Pro via USB to a standalone instrument, you should experience virtually zero latency, that is, no noticeable delay.

There are a bunch of factors that can contribute to latency, but you’ll want to just start with checking some of the basics. First, do a complete restart of your computer and see that unnecessary apps aren’t running.

Go into the Preferences/Settings for the standalone Arturia app you’re running, and check your buffer size. Should default to 512 samples / 44100 Hz sample rate. Press the “Play” button to hear a test sound. There should be practically no delay from clicking the Play button on screen to hearing the sound.

I’m a Mac person, not Windows so I can’t help you with specifics on that end, but a search for “reduce midi latency on windows 11(or whatever)” should get you in the zone.

Also, if there is still an issue, I might also try to disconnect unnecessary USB devices to rule out something causing a problem on the USB bus.

Come back for more advice, but I think this should be a good start. And knowing the issue is called “latency” will help in finding the exact solution.

1 Like

How long is the delay? How are you listening to the audio? Do you get the delay with the on-screen keyboard, or only with the KeyStep?

There was someone else in here with this problem, and it turned out to be because they were using Bluetooth speakers. Bluetooth will always add a lot of latency. Could that be the problem?

1 Like

Are you using an audio interface that offers true ASIO drivers and is ASIO enabled in your Arturia software instruments?

If not, that’s probably your issue.


Sorry about the slow response, I’m travelling at the moment. I’m not using a audio device or bluetooth speaker. I’m listening with my headphones plugged in to the audio output of the laptop.

Looking in the settings of the standalone instrument I saw the menu - Audio Midi Settings. Here I can change the driver which seems to improve things. Specifically choosing ASIO helped.

edit - So I’m guessing here that some of the drivers I can choose from the software synths settings are shared and some are exclusive. The exclusive one has low latency but doesn’t share the driver with other apps. I’m just experiencing no audio from my web browsers (firefox and chrome) and spent a while trying to trouble shoot it before realizing the above…

…correct me if I’m wrong.