Control MiniFreak AND Analog Lab (Computer) with KeyLab MK II

I’m trying to get this setup running:

  • KeyLab MK II is my main controller, from here I want to play all instruments
  • MiniFreak connected via Midi, set to Midi Channel 3
  • Analog Lab on my computer via USB

Problem is, I can’t (at least I don’t know how) get Analog Lab to only accept Midi input from a specific channel, it seems to listen to ALL channels and therefor always plays notes, even if I swith the KeyLab to channel 3, where MiniFreak is listening.

How can I achieve, that Analog Lab listens only to one Midi channel (i.e. 10)?


Hi, unless I’m missing something, it’s in the Settings tab of AL:

Click on the gearwheel in the upper right corner.
You can select your Midi channel under the “settings” tab.
Btw Arturia’s synths settings are always there.

That was too simple :face_with_peeking_eye:

Thank you!