[Bug]s and [Feature Request]s

hey all,

just got the astrolab this weekend and for the most part i am really enjoying it. that said i have run into a few bugs already. i understand this is a brand new device and i am sure arturia will keep improving the experience with firmware updates, but figured i’d start a thread here to list some of the issues i’ve experienced and get some feedback from others in the community.

Bugs:

  • right out of the box there was some frustration getting the astrolab connect android app to properly sync with the device. probably attempted 3 or 4 times before i was able to successfully sync, even though the keyboard and the app were both clearly connected to my wifi. anyway, finally worked after connecting to the computer and updating the astrolab firmware, so maybe not technically a bug, but the remediation process could have been a bit smoother or maybe i could have updated the firmware directly from the astrolab itself which did have a working wifi connection. either way, a frustrating start to my experience with the keyboard.

  • at some point during the first day of use, I realized certain presets were no longer producing audio. i initially thought it was a connection problem on my end, but most presets still worked, only a few (certain organs like the Jazz B3) would not make any sound at all. i followed troubleshooting steps and performed a reset of factory prefs which did in fact restore sound on these presets and thankfully did not lose the handful of likes and custom user presets i had already created, but no idea what caused this problem in the first place and whether it may happen again at some inconvenient time.

  • sometime after this i also noticed that the list of “Types” in the preset browser was only showing a small subset of the full list. Maybe 4 or 5 instead of the usual longer list. Don’t know if this happened before or after the reset of factory prefs, but a restart of the keyboard restored the full list.

  • had some issues getting a sustain pedal working. the korg damper pedal DS-1H would not work properly even after going into settings and updating the polarity. switched out for another brand of pedal and was able to get it working, but not sure why that pedal which works with several other keyboards i own would not work with the astrolab.

Feature Requests:

  • as mentioned above, the troubleshooting steps i took did retain my user likes and custom presets, but i wasn’t positive that this would be the case. So i went looking for how to sync these presets from the astrolab to analog lab on the computer and it does not seem to be possible currently. I see how i can sync from analog lab to the keyboard, but not the other way around. I do remember reading something about connecting a USB drive to the back of the astrolab to backup settings, but seems like i should be able to sync to the computer i already have connected via USB.

  • adding confusion to my sustain pedal issues, it seems that the arp hold function is tightly bound to the sustain on message from the pedal. stepping on the sustain pedal while playing an arp with hold activated will toggle the hold setting to off. requiring you to go back into the shift menu to reactivate hold. i am contrasting this with the behavior on my novation midi controller where latching the arp is not synonymous with holding down the sustain pedal. (stepping on sustain while a latched arp is playing simply lets each individual note played by the arp ring out until the pedal is released, arp remains latched). it would be nice if the relationship between the sustain pedal and the arp hold were clarified a bit, perhaps with some user options as to how it should behave.

  • speaking of the arpeggiator, you should be able to adjust the gate.

That’s about all I can think of at the moment. Curious to hear if others have experienced these or other issues. Hopefully there are also some arturia developers in these forums who might be able to provide some useful feedback or at least be made aware of the issues to address in future updates.

2 Likes

I didn’t have any of the other problems yet but I cannot get my iPhone to connect to the Lab through either network at home. Only direct connect to the keyboard’s built in wifi seems to connect. Really annoying. Hope this gets sorted out in a firmware update. Happy to send debug info if needed.

Hi @doubletriplezero and @wajeremy and welcome to The Sound Explorers Forum!

Sorry to hear you’re having some issues with your new AstroLab-61, it looks like a MIGHTY keyboard btw!
It might be worth you logging in to your account to contact our support team that will help you to fix this situation as this is such a new piece of gear.

Also, many thanks for the other ideas you’ve provided.
I’ll mark the post accordingly so our team are aware of it.

HTH!

Ps,
Please make sure to subscribe to our Newsletter to be the first to know about the latest from Arturia.

1 Like

I feel for you.

I bought Native Instruments S88 mk3 in January, when I turned it on, I was presented with the S88 screen telling me to go to their site and install the latest firmware.

No choice, I couldn’t quit out of it, if I wanted to use this keyboard I’d just spent £1069 on, I had to download the firmware. So I followed the instructions and halfway through the firmware update it failed. I wasn’t alone, forum was full of people suffering the same, in some cases they had bricked their keyboards.

In the end I had to follow instructions from another user which involved editing files in order to get it to update. NI have said it was a problem at Microsoft which has since been fixed with an update.

Personally I was aware of these problems before I bought it and had also bought the Arturia keylab 61 at the same time, so I still could still play music. But had I been a person who had seen it in a music shop, decided to buy it, only to get home to find they can’t use it after all and even after following NIs instructions the updates simply won’t work, well I wouldn’t have been happy (and this (amongst other things) got the S mk3 series (and NI) some really bad press)

Like you, a lot of people also had problems getting their pedal to work with the S series mk3.

Sadly I think these things will happen more and more as basically they are a pc in a case with a keyboard attached and something we would think of as simple, like plugging in a pedal, becomes a real pain. Especially for early users.

That said, I love my S88 and I hope you love your AstroLab too.

1 Like

Seems like I just needed to turn it off last night then try it again today and it connected fine. Haha. I am not jinxing it.

2 Likes

Thank you, I have been in touch with the support team as well and they have confirmed that the firmware update to 1.1.6 should address most of the initial bugs I reported and taken note of the additional feature requests. For the most part my experience with the astrolab has been great and I know that any new instrument with so many capabilities is bound to have a few bugs on initial release. So far, support has been very responsive and helpful and I’m sure future updates will resolve outstanding issues and make this keyboard even better than it already is.

4 Likes

Adding to the bugs, I am pretty sure that the MIDI implementation on Astrolab is far from perfect. I have posted about this a couple of times on the sound explorer forum but this looks like where I should have posted originally, I am new here, apologies.

I have been unable to send MIDI to Astrolab from a Roland Fantom. Hung notes are the problem. I thought that I had solved for this with a Fantom setting but the hung notes are back so to trouble shoot further I sent MIDI to Astrolab from a Deepmind 12, same problem. And the hung notes will continue until the preferences are reset with the onboard utility and the system is rebooted. Would be very grateful if someone could test sending MIDI to Astrolab from another synth…I dont know if this will get fixed in a firmware update or if I have a defective unit. My first unit had a defective encoder wheel, fingers crossed that I dont have bad HW again. Thanks!