Audofuse Studio - Windows 10/11 does not recognize device

I have an Audiofuse Studio that will NOT be recognized by two Windows computers.

One is a Windows 10 Home, which the AFS was working on when I first bought it aprox. 2 years ago. I first had a non-connection issue a few months after receiving the unit. The issue was reported immediately but the suggested fixes didn’t work.

Connecting to another computer has the same results. The drivers were installed because they would appear in whatever software I was using. Nothing would happen, if I selected the AFS as my audio device. When trying to open the AF control center, it tells me that it can’t connect because there are no devices connected.

At that point, I thought that it was a faulty USB port and asked if I should return the unit. I never got a reply to that and unfortunately, at the time, I had to move suddenly and had to put everything on hold.

I am now able to get back to the issue and it’s still there. This time, I have a brand new Windows 11 Home PC (Dell XPS8960) that won’t recognize the AFS. Everything else that I own that has audio drivers, installs and works as it should. I am still getting the control center error that tells me no device is connected. This is what is leading me to believe the AFS has a faulty USB port.

In Windows device manager, it never shows the AFS as an audio device. When connecting or disconnecting the USB cable (the factory supplied one or any other) the device manager screen will “flash” like it’s trying to connect or disconnect. Still, it is never shown as a connected device.

Other things I have tried:

Factory reset
Uninstall and reinstall all Arturia software and drivers (many times)
Different USB ports (USB 2 and 3)
USB powered hub
Restarting computer after installing driver

The AFS appears to be working as a standalone device. I tried connecting to the instrument input and I get sound into the headphones.

I reached out to Arturia Customer Service by replying to my old ticket (they said to reply there when I was ready) and I started a new one just in case.

It’s been a week with no reply. I did get e-mail confirmation that they got my support requests.

I don’t know what else to try so I thought maybe, someone might have had a similar issue and could post what they did to solve the problem.


HI @AFUser01 and welcome to The Sound Explorers Forum!

Sorry to hear this is still an issue for you, it must be highly frustrating.

I’ve sent you a PM.

I read your PM and will let you know.

If they are so busy responding to other customer issues and taking this long to reply, it makes me wonder about the actual quality of their products.


I got a reply Monday and was told that my ticket was sent to the After Sales department.

No reply from them at all this week.

All I want to know is, if it is something I can repair myself or what is the repair procedure from here on. I don’t know why they can’t answer that instead of passing my service ticket around.

I finally got a repair estimate last Friday but it didn’t include anything about paying or where to ship. They just wanted me to sign it and send it back.

I had other questions so I replied to the e-mail and they still have not returned a response. I’m sure they will take their usual 1 to 2 weeks to reply.

This is ridiculous. It’s over a month since reaching out and I am still waiting to ship it for repair. I expected to have it fixed and returned by now.

Does anyone know if there is a working phone number to their customer support in the USA? The only number they gave me is in France.

I got a reply today from Arturia accusing me of NOT replying to their messages. LOL!!!



Before signing your document I need some questions answered but you ignored that EMAIL and claim I am holding YOU up.
Your support request number (933239) is now pending for 10 days.

We yet received no news from your side, and may need your feedback to resolve your request.

Can you please get back to us as soon as you can?

/!\ After 20 days pending, your case will be considered as solved and automatically closed.

Best regards

The Arturia support team.