Audiofuse Rev 2 Output into Logic Pro X Garbled and Distorted but working as expected in Reaper

Just bought a Aufiofuse Rev 2. running 1.2.3

Connected to a M1 Macbook Pro 16gb RAM running Sonoma 14.1.2 through a USB 3 hub.

Computer audio is fine and I have the dial set fully to “computer”.

Everything seems fine except for when I try to use the Audiofuse as a source in Logic Pro X. I get nothing but garbled clicks and pops. I’ve tried changing all settings in Logic but nothing helps. Sounds played from within Logic, like VST’s, are fine. It’s just the incoming audio from the Audiofuse that isn’t working.

I downloaded a copy of Reaper to rule out the hardware being the issue and Reaper works as expected. Incoming audio sounds like it should. Why would Logic be causing these issues if Reaper is fine???

1 Like

Hi @Bork and welcome to the Sound Explorers Forum.

I don’t have an Arturia interface myself, but it sounds like the buffer could need increasing on the interface when using it with logic.

Can you change this from the Audiofuse control software?


Please make sure to subscribe to our Newsletter to be the first to know about the latest news from Arturia.

Don’t know how to increase buffer size on the Audiofuse from a Mac. I only see ASIO instructions in the manual.

I’m not currently in front of my machine so cannot check the manual, is there a setting in the Audiofuses control panel perhaps?

Don’t see anything about buffer size for the hardware on a Mac in either of the manuals unfortunately

HI @Bork

I think it might be an idea for you to log in to your account to contact our support team that will help you to fix this situation.

Best :zap:

Hi @Bork ,

Did’nt you set the buffer size in Logic’s Preferences/ Projects, when you set up Audiofuse?

How did you set this settings for Reaper, if not in Reapers preferences/ Projects?

Changing buffer size in Logic makes no difference in this case.

I have decided to go with Reaper as my DAW as I have also tested in Garageband and the Audiofuse worked as expected. It’s an issue with the copy of Logic I have and not an issue with the Audiofuse itself.

hi again @Bork,

I think you are right it’s not about Audiofuse and Arturia.

But i suggest you ask in a logic forum if there are reasons to this and if there can be done something.
I’m not on MAC.

Ended up solving the issue this morning.

For some reason software monitoring had been turned off in Logic. Turning it on got everything working as expected.

Before buying the Audiofuse I was using a RME FireFace 400 with adapters to a Thunderbolt connection. Not sure if that had something to do with it but we’re good now!

Thanks for the replies!

Hey @Bork

Great stuff!

Glad to see you’re up and running properly again now! :sunglasses: